locked
IIS Advanced logging support on windows 10 RRS feed

  • Question

  • User-517453363 posted

    Is IIS advanced logging officially supported on IIS 8.5 and IIS 10?  The IIS Advanced logging homepage says that it works on IIS 7, 7.5, and 8 but it can be installed on 8.5 and even 10.0 with a little tweaking.

    Wednesday, August 8, 2018 6:06 PM

All replies

  • User690216013 posted

    with a little tweaking

    Usually that does not mean it is supported there.

    Wednesday, August 8, 2018 6:13 PM
  • User-517453363 posted

    It appears the only reason it needs tweaking is because there is a bug in the installer.  Looking at the logic, it seems like it was intended to install on any version of IIS greater than 7.0

    Wednesday, August 8, 2018 6:17 PM
  • User690216013 posted

    It appears the only reason it needs tweaking is because there is a bug in the installer.

    Your understanding is wrong. Microsoft only updated supported components with an IIS 10 compatible installer, https://blogs.iis.net/iisoobs

    So that's not "a bug" but a "feature".

    Wednesday, August 8, 2018 6:32 PM
  • User121216299 posted

    Hi ShaunHathawa...,

    If it is supported then Microsoft will always modify the documentation.

    If it is not mentioned there which means currently as per Microsoft it is not supported.

    It has nothing to do with whether you are able to install it or not.

    Many other software which were developed for Windows 7 OS can also be installed on Windows 10.

    It doesn't mean that it will work correctly on Windows 10 as it was able to work on Windows 7.

    Regards

    Deepak

    Thursday, August 9, 2018 1:26 AM