none
App Insights and JDK, Node JS Versions supported RRS feed

  • Question

  • I find the documentation clearly calling out that .NET v2.0 and below is not supported by Application Insights. This means that .NET v3.0 and above is supported by App Insights with the recommendation being v4.6

    Is there a similar restriction for specific versions of Java and Node.JS? Please advice.

    Thursday, September 26, 2019 8:23 AM

Answers

  • Version 2.5 of the SDK that was just released explicitly allows for Java versions 9-12: https://github.com/Microsoft/ApplicationInsights-Java/releases

    The Node version of the SDK isn't tied to a specific version. My suggestion here would be to post an issue on the Github repo if something comes up with the version you are using. The team will decide whether or not they want to support a specific version, but they are more likely to support an older version if customers request it. For comparison, Azure App Services supports Node versions 4.4+.

    The important thing for versioning is the SDKs. You can use the base API to utilize the tool in pretty much any version of any language that can make web requests. However, the dev experience is much better if you are able to utilize an SDK.

    Thursday, September 26, 2019 4:39 PM
    Moderator

All replies

  • Version 2.5 of the SDK that was just released explicitly allows for Java versions 9-12: https://github.com/Microsoft/ApplicationInsights-Java/releases

    The Node version of the SDK isn't tied to a specific version. My suggestion here would be to post an issue on the Github repo if something comes up with the version you are using. The team will decide whether or not they want to support a specific version, but they are more likely to support an older version if customers request it. For comparison, Azure App Services supports Node versions 4.4+.

    The important thing for versioning is the SDKs. You can use the base API to utilize the tool in pretty much any version of any language that can make web requests. However, the dev experience is much better if you are able to utilize an SDK.

    Thursday, September 26, 2019 4:39 PM
    Moderator
  • Thanks for clarifying. 

    So would it be correct to say that the App Insights SDK would support Java 9 - 12 but for anything below 9, the Base API Needs to be used and the SDK will not work? 


    Thursday, October 3, 2019 9:41 AM
  • It might work on older versions so you can try, but it isn't officially supported. The safe route is to use the API directly.

    You can make a request through the Github repo to support older versions, or if there is a specific error that is blocking you from you can post the error there and see if they would be willing update the SDK to resolve it. Just as I mentioned with the Node SDK, the best way to have the version range extended is to ask for it.

    Thursday, October 3, 2019 4:50 PM
    Moderator