none
Can .Net 2.0 exe load assemblies built in .Net 3.5? RRS feed

Answers

  • There have been some minor changes (type forwarding of generics works in 3.5 = 2.0 SP2, but not in 2.0 RTM), however it is very unlikely you will hit them.

    You can learn more about CLR and .NET versions on wikipedia.

    -Karel

    • Marked as answer by SamAgain Friday, April 2, 2010 10:19 AM
    Tuesday, March 30, 2010 5:15 AM
    Moderator
  • The CLR didn't change in from 2.0 to 3.5. It is only additional assemblies and the C# and VB.NET compiler change.  So if all the dependent assemblies are available then it shouldn't be an issue.
    Thanks Naveen http://naveensrinivasan.com
    • Proposed as answer by NaveenS Monday, March 29, 2010 2:57 PM
    • Marked as answer by SamAgain Friday, April 2, 2010 10:19 AM
    Monday, March 29, 2010 2:43 PM

All replies

  • Hi,

    If framework installed.it will work.


    Best Regards, C.Gnanadurai ----------------------- Please mark the post as answer if it is helpfull to you
    Monday, March 29, 2010 12:30 PM
  • Hi,

    If framework installed.it will work.


    Best Regards, C.Gnanadurai ----------------------- Please mark the post as answer if it is helpfull to you
    Monday, March 29, 2010 12:30 PM
  • The CLR didn't change in from 2.0 to 3.5. It is only additional assemblies and the C# and VB.NET compiler change.  So if all the dependent assemblies are available then it shouldn't be an issue.
    Thanks Naveen http://naveensrinivasan.com
    • Proposed as answer by NaveenS Monday, March 29, 2010 2:57 PM
    • Marked as answer by SamAgain Friday, April 2, 2010 10:19 AM
    Monday, March 29, 2010 2:43 PM
  • There have been some minor changes (type forwarding of generics works in 3.5 = 2.0 SP2, but not in 2.0 RTM), however it is very unlikely you will hit them.

    You can learn more about CLR and .NET versions on wikipedia.

    -Karel

    • Marked as answer by SamAgain Friday, April 2, 2010 10:19 AM
    Tuesday, March 30, 2010 5:15 AM
    Moderator
  • I will , but if this assembly has any .NET 3.5 specific features then those worn't work under 3.5.
    .NET 3.0 and 3.5 are applied as a patch on .NET 2.0, this is known a Red-bit and Green-bit concept.
    http://dotnetpassion.blogspot.com/2007/09/red-bit-and-green-bit-assembly-model.html 
    Vidya Vrat Agarwal. MCPD,MCTS, MCT, MCSD .NET, MCAD .NET, MCSD. http://dotnetpassion.blogspot,com
    Wednesday, March 31, 2010 5:38 PM