locked
Windows 7 RTM and ASP.NET Development Server RRS feed

  • Question

  • User-577650458 posted

    Update:

    If I create a new website in Visual Studio it works, the problem is opening a solution previously created.  the solution was created in VS2008, on an XP Professional machine, if that matters....


    I just installed Windows 7 RTM and Visual Studio 2008. 


    When I try to run a file system web site from VS, it cannot properly run the development web server.  What I get is a window describing the use of the WebDev.Webserver.exe application, and then another window that says "Unable to connect to ASP.NET development server".  It is as if visual studio is calling the webserver application, but not passing any parameters to it, causing it to fail. 


    Has anyone come across this or have any ideas on how to fix it?


    Thanks

    Friday, August 14, 2009 2:39 PM

Answers

  • User-1935260616 posted

    I know it's an obvious thing but, are you running the Visual Studio as administrator?

    Ok, I supose you are, so, you can try some steps (from Rosario Carbone, http://forums.asp.net/t/1189567.aspx):

    Step 1: Select the “Tools->External Tools” menu option in VS or Visual Web Developer.  This will allow you to configure and add new menu items to your Tools menu.

    Step 2: Click the “Add” button to add a new external tool menu item.  Name it “WebServer on Port 8010” (or anything else you want).

    Step 3: For the “Command” textbox setting enter this value: C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\WebDev.WebServer.EXE (note: this points to the web-server that VS usually automatically runs).

    Step 4: For the “Arguments” textbox setting enter this value: /port:8010 /path:$(ProjectDir) (or any port you like)

    Step 5: Select the “Use Output Window” checkbox (this will prevent the command-shell window from popping up.

    Once you hit apply and ok you will now have a new menu item in your “Tools” menu called “WebServer on Port 8010”.  You can now select any web project in your solution and then choose this menu option to launch a web-server that has a root site on port 8010 (or whatever other port you want) for the project.

    You can then connect to this site in a browser by simply saying http://localhost:8010/.  All root based references will work fine.

    Step 6: The last step is to configure your web project to automatically reference this web-server when you run or debug a site instead of launching the built-in web-server itself.  To-do this, select your web-project in the solution explorer, right click and select “property pages”.  Select the “start options” setting on the left, and under server change the radio button value from the default (which is use built-in webserver) to instead be “Use custom server”.  Then set the Base URL value to be: http://localhost:8010/


    In the same thread you have this solution:

    I had the same issue w VS2008. My solution wasnt found on the web. After using sysinternals process monitor I found the path VS was using to execute the server was incorrect. I guess MS didnt take into account my system was a 64bit system. So I had to move my DevServer folder to C:\Program Files\Common Files\microsoft shared\DevServer dir. In its present C:\Program Files (x86)\Common Files\microsoft shared\DevServer it was usless since MS was looking in the wrong location.

    (from spankster)


    You can also try this thread: http://forums.asp.net/t/1189567.aspx


    Good luck ;)

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, August 15, 2009 2:28 PM