none
Installation issue - on Windows 7 - Require a "Token Provider Service" RRS feed

  • General discussion

  • Attempting to install on Windows 7 (Development/trialling)

    Getting error:

    Starting
    Endpoint=sb://DavidT-7L.syncsoft.com.au/WorkflowDefaultNamespace;StsEndpoint=https://DavidT-7L.syncsoft.com.au:9355/WorkflowDefaultNamespace;RuntimePort=9354;ManagementPort=9355

    Processing completed
    Installing auto-generated certificate.
    Granting 'Log on as Service' privilege to the RunAs account.
    Workflow Manager configuration starting.
    Configuring Workflow Manager runtime settings.
    Could not successfully create management Service Bus entity 'WF_Management/WFTOPIC' with multiple retries within a timespan of 00:02:05.7892585.. The exception of the last retry is: The token provider service was not avaliable when obtaining a token for 'https://davidt-7l:9355/WorkflowDefaultNamespace/$STS/Windows/'..

    Do I need an STS?  Do i have to install sharepoint (Foundation 2012) as well (for its STS)?

    Any ideas?

    Thanks

    david tuke

    Friday, June 28, 2013 8:16 AM

All replies

  • the STS should have gotten installed as part of installing ServiceBus Server.

    Maybe you hit a temporary glitch. Try unconfiguring / reconfiguring.

    Tuesday, July 2, 2013 1:16 PM
  • I'm having a similar issue now. I have noticed that when i navigate to the URL in the error message, if you keep it at $STS it throws a 400 error. If you change it to $sts (lower case) it navigates fine (but throws an error regarding to not having the credentials properly, which should be expected). I am waiting on a solution, but if this helps you, then good.
    Friday, March 7, 2014 11:51 AM