locked
Trouble Building HealthVault Package Project RRS feed

  • Question

  • Hi,

    I downloaded Windows HealthVault DDK (hd_ddk.msi) from HealthVault website and tested out building the sample projects.  The WPDdriver and DriverSetup projects were built successfully but not the MSI package project.  Below is the error log from the FabrikamBloodPresssurePackage.sln.  Similar errors also occur in other sample projects.

    ==================================================================

    1>Build log was saved at "file://c:\Program Files (x86)\Microsoft HealthVault\DDK\Code\DriverPackages\FabrikamBloodPressure\WpdDriver\Release\Win32\BuildLog.htm"

    1>FabrikamBloodPressureWpdDriver - 0 error(s), 1 warning(s)

    3>------ Rebuild All started: Project: FabrikamBloodPressurePackage, Configuration: Release Win32 ------

    3>Deleting intermediate and output files for project 'FabrikamBloodPressurePackage', configuration 'Release|Win32'

    3>Building FabrikamBloodPressurePackage-Win32.msi installation package

    3>A subdirectory or file ..\Release\msi already exists.

    3> 1 file(s) copied.

    3>The system cannot find the path specified.

    3>The system cannot find the path specified.

    3>Could Not Find c:\Program Files (x86)\Microsoft HealthVault\DDK\Code\DriverPackages\FabrikamBloodPressure\Release\msi\FabrikamBloodPressurePackage-Win32.wixobj

    3>copy msi files to the parent solutions

    3>A subdirectory or file ..\..\Release\msi already exists.

    3>..\Release\msi\*.*

    3>The system cannot find the file specified.

    3> 0 file(s) copied.

    3>Project : error PRJ0019: A tool returned an error code from "copy msi files to the parent solutions"

    3>Build log was saved at "file://c:\Program Files (x86)\Microsoft HealthVault\DDK\Code\DriverPackages\FabrikamBloodPressure\DriverPackage\Release\msi\BuildLog.htm"

    3>FabrikamBloodPressurePackage - 1 error(s), 0 warning(s)

    ========== Rebuild All: 2 succeeded, 1 failed, 0 skipped ==========

    Here is build environment:

    Windows 7 x64

    Visual Studio 2005 SP2

    Windows DDK  v7600.16385.1

    Wix 2.0

    Do you have any idea how to resolve this?

    Thanks.

    huhuyaya

     

     


    Tuesday, May 17, 2011 11:39 PM

Answers

  • Hello,

    I got it resolved.  I had the wrong path for the packaging tool.  It needs to be in the Program Files (x86) folder. 

    Thanks.

    huluyaya

    Thursday, May 19, 2011 3:42 PM

All replies

  • Hello,

    The issue is not reproducible at my end.

    I recommend to refer the troubleshooting steps mentioned in the MSDN document for Project Build Error PRJ0019.

    Thank you,


    Anish Ravindran
    Wednesday, May 18, 2011 5:07 PM
  • Hello,

    I got it resolved.  I had the wrong path for the packaging tool.  It needs to be in the Program Files (x86) folder. 

    Thanks.

    huluyaya

    Thursday, May 19, 2011 3:42 PM