none
Visual Basic - Print A scrollable form LISTVIEW

    Question

  • I am attempting to print a LISTVIEW that has more than one page, but it will only print one (1).  I then used the Scrollable Form as directed in the documentation.  The following:  Printform1.Print(Me, Powerpacks.Pringing.Printform.PrintOption.Scrollable)  but I still only get one page of the listview.  What property should I used to print all the pages not just one page at a time.

    Ed.


    ecb

    Saturday, December 29, 2012 9:28 PM

Answers

All replies

  • PrintForm can only print what will fit within the display area of the monitor containing the form and only one page.  For more control over printing, use the WF PrintDocument or the WPF PrintDialog.
    Saturday, December 29, 2012 11:27 PM
  • When I do a find on Printdocument or WPF Printdialog I find reference to them but I guess I am looking for instructions on how to print a listview with all the pages.  Instructions like DO This, then DO This, Then Do This.  Is there a link with instructions?

    Ed.


    ecb

    Sunday, December 30, 2012 6:10 AM
  • Or you can use this custom control Printable ListView.

    Happy holidays.


    Shanks Zen
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, December 31, 2012 7:59 AM
    Moderator
  • Zen, when I attempt to signon to download the PRINTABLE LISTVIEW  btI get message SOMETHING BAD HAPPENED - INVALID VIEW STATE.    I read the options and I am not sure what is the problem.  I did ciick Cookie Test and reveive message: COOKIES ARE NOT ENABLED OR ARE BEING BLOCKED.  Question:  If the cookie is the problem what must I do to resolved the problem?

    Ed.


    ecb

    Tuesday, January 1, 2013 8:19 PM
  • Zen, when I attempt to signon to download the PRINTABLE LISTVIEW  btI get message SOMETHING BAD HAPPENED - INVALID VIEW STATE.    I read the options and I am not sure what is the problem.  I did ciick Cookie Test and reveive message: COOKIES ARE NOT ENABLED OR ARE BEING BLOCKED.  Question:  If the cookie is the problem what must I do to resolved the problem?

    Ed.


    ecb

    Hmm, you could try it again in another Web browser.

    Best regards,


    Shanks Zen
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, January 2, 2013 8:36 AM
    Moderator
  • Zen, thanks I followed your instruction and I download the zip.  Now when I attempt to run it I get message.  TEST.SOLUTION.SIN is READ-ONLY on disk and can not be migrated.  To migrate the solution, change the permissions on the solution file to allow modification and re-open it.  How do I change permissions on the SIN file?   I am using Windows 8.

    Ed.


    ecb

    Wednesday, January 2, 2013 5:37 PM
  • Zen, thanks I followed your instruction and I download the zip.  Now when I attempt to run it I get message.  TEST.SOLUTION.SIN is READ-ONLY on disk and can not be migrated.  To migrate the solution, change the permissions on the solution file to allow modification and re-open it.  How do I change permissions on the SIN file?   I am using Windows 8.

    Ed.


    ecb

    Right click the file, go to properties, and uncheck "ReadOnly"

    “If you want something you've never had, you need to do something you've never done.”

    Don't forget to mark helpful posts and answers ! Answer an interesting question? Write a new article about it! My Articles
    *This post does not reflect the opinion of Microsoft, or its employees.

    Tuesday, January 29, 2013 2:23 AM
    Moderator
  • Paul, I have view the test.solution.sin file and all related files in the download and none have the READONLY check on.  I still get the same error message about test.solution.sin is READ-ONLY.  What am I not understanding.  Bear with me I am still a NEWBEE.

    Ed.


    ecb

    Tuesday, January 29, 2013 5:56 PM