locked
Invalid transport port RRS feed

  • Question

  • When I try to run a simple VPL pgm (tutorial 1) it can't connect to DSS with "Valid transport port not spec'd".
    When i try to view the pgm at http://localhost:50000/Model/app it says i'm not logged in.

    I also can't see http://127.0.0.1

     

    I have the April CTP and I'm just running VPL under XP SP2.

     

    Thanks,

    Peter

     


    Tuesday, May 20, 2008 4:31 AM

Answers

  • Found the problem !!!!

    Added http://localhost    to Local intarnet instead of trusted sites.

    That was the fix for me. Simple little errors are costly. Lost lot of time scratching head on that one!

    Hope this helps someone else!

     

    sparktom

    Tuesday, May 27, 2008 6:39 PM

All replies

  • Are you logged in as an Administrator? If not, then you might need to use the httpreserve command to reserve port 50000 for your use. From a DSS Command Prompt window, try:

    httpreserve /p:50000 /user:xxx

    where xxx is your login username.

     

    You won't see anything on 127.0.0.1 unless you are running a web server on your PC, e.g. Internet Information Server. In a "plain vanilla" installation of XP, IIS is not installed automatically.

     

    Trevor

     

    P.S. In VPL, check the Port Settings in the Run menu.

    Tuesday, May 20, 2008 1:23 PM
  • Hi Trevor.

     

    Something strange has happened, it now works!

     

    Is MSRS assuming IIS will show me the code at http://localhost:50000/Model/app ?

     

    Thanks,

    Peter

     

    Tuesday, May 20, 2008 3:24 PM
  • OK, you can get the error that you saw if you try to run two copies of a VPL program, or start up DssHost twice. So maybe there was an old instance lurking in the background.

     

    MRDS does not require or rely on IIS. The DssHost program has a built-in web server. That is what you are connecting to when you specify port 50000 on localhost. When you run DssHost you supply this port number on the command line. If you use VPL it is in the Port Settings.

     

    There are actually two ports -- one for web browsing and another for fast TCP/IP message transfers, although DssHost can actually work with just one port if necessary. By convention, these ports are 50000 and 50001 but they can be any two unused ports.

     

    Trevor

     

     

    Wednesday, May 21, 2008 6:33 AM
  • Thanks Trevor that's very interesting.

     

    Today's question is: why doesn't my program show up at http://localhost:50000/Model/Application as it's supposed to?

     

    I had to add localhost to my trusted sites, but the Source shows:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META http-equiv=Content-Type content="text/html; charset=windows-1252"></HEAD>
    <BODY></BODY></HTML>


     

    Peter

     

    Wednesday, May 21, 2008 4:30 PM
  • Sorry, I don't have an answer for that, although I have a feeling I've seen it before. Maybe somebody else in the forum has an answer?

     

    First try browsing to http://localhost:50000

     

    Then look in the Service Directory and see if you can find /Model/Application.

     

    Trevor

     

    Thursday, May 22, 2008 8:34 AM
  • http://localhost:50000 

    shows the same blank screen as before with apparently the exact same Source.

     

    Peter

     

    Thursday, May 22, 2008 1:33 PM
  • I tried Run Dss Node from the MSRDS menu and got a blank DOS box and a blank browser screen.

     

    Surely that's got to tell someone something useful?

     

    Peter

     

    Friday, May 23, 2008 5:56 PM
  • I take that back -- it's highly unlikely it'll tell anyone anything; but it should suggest a next step, shouldn't it?

     

    Peter

     

    Friday, May 23, 2008 6:39 PM
  • Maybe the problem is that I have the web download version and the file it can't find hasn't been downloaded yet and it can't figure out how to get it?

    Peter

     

    Saturday, May 24, 2008 1:19 AM
  • I downloaded the full version of MSRS but haven't noticed much improvement.

     

    I've given up trying to get the Basic Sim. Environment (from XP_Start->MSRDS->VSE) to work.  I have a reference to that in Morgan's book at p.79 for version 1.5, so maybe they didn't fix it.

    I built the Sim Tutorial 1 and it does bring up the DSS Dirn Dlg but there are several error msg's and nothing else happens.  The thing that gets me is that you can't copy & paste from the msg's in the Run window! 

     

    I'm on the brink of giving up on MSRS.

     

    Here are my notes:

     

    Try Sim. Tut. 1
    C:\Documents and Settings\Peter Chatterton\Microsoft Robotics Dev Studio 2008\samples\SimulationTutorials\Tutorial4
    but we start with vpl tut. 4 drive by wire
    Questions:
        Should the GenericDiffDrive be 2 objects or one?
        (it said "Now insert a Generic Differential Drive service ")
        -- I used one, but it wouldn't let me set the left/rt values for the top one.
    Saved to C:\Robotics\MSRS\SimTut1
    Run shows a DSS Dirn Dlg a small blank (all white) window entitled MS VPL Hosting Application.
    The browser shows a new window: http://stylistic:50000/model/simtut
    (why did it drop the 1 in simtut1?)
    but as usual it's empty, as is http://localhost:50000/.
    The Run window in VPL showed several manifests being loaded successfully but it fails retrieving metadata from proxy asembly c:\...simulationEngine.proxydll 
    I can't give any more info since it doesn't support the clipboard and it doesn't scroll to the right,  Rt click shows a copy command with Ctrl-C, but nothing happens.  Would any of the files give useful info?

     

    Peter


     

    Sunday, May 25, 2008 9:49 AM
  • Hi Peter,

     

    I'm sorry you are having such trouble with MRDS, but I have not seen so many different problems before.

     

    The fact that you get an empty DOS window is very suspicious. There is something seriously wrong with your installation if you can't get a command prompt to run.

     

    Please try the following.

     

    Download and install the V1.5 Refresh. After all, the April CTP is a beta version, so you should probably start with an official release. You can install V1.5 side-by-side with V2.0 and it won't cause any problems (except that the file association for .mvpl will point to the old VPL).

     

    With V1.5 installed, start a DOS command prompt window from the MRDS menu.

     

    At the command prompt type:

    dsshost /p:50000

     

    Now start a web browser and browse to http://localhost:50000

     

    Please let me know what happens at this stage, or if you encounter any errors along the way.

     

    By the way, did you manually install DirectX 9c from the Microsoft download site? Sometimes the April CTP does not install this properly.

     

    And lastly, in VPL you can have the same activity (service) appearing as several separate boxes in the diagram. (This is a convenience so that you don't have lots of connections crossing over each other all trying to get to the same box.) They all refer to the same service however. If you were to drag a new Diff Drive service to the diagram, then VPL should ask you if you want to create a new instance or use the existing one. New instances have a number appended, e.g. GenericDifferentialDrive0, GenericDifferentialDrive1, etc.

     

    You only need one instance of the Diff Drive for VPL tutorial 4 because there is only one robot. A Diff Drive controls two wheels.

     

    Trevor

     

     

     

    Monday, May 26, 2008 12:45 AM
  • Hi Trevor,

     

    I installed all of 1.5
    It had a problem with AGEIA but continued.  This might have been because it was already installed.
    It installed the DirectX runtime but didn't uninstall the SDK that I'd downloaded separately.

    I'll uninstall the SDK to save space (unless you think not).
    Add/Remove shows MSRS as 135.00MB
    ran dsshost /p:50000 in a new MRDS dos box:
        "Did not find VS shell or .Net shell. If you have VS and/or .Net SDK
        installed then you can update this file to point to the right location:
        (C:\Microsoft Robotics Studio (1.5)\sdkenv.cmd)

    -- not sure what to do about this, I have bits of Vis Studio and .NET but don't know about any shell.
        C:\Microsoft Robotics Studio (1.5)>dsshost /p:50000
        Rebuilding contract directory cache. This will take a few moments ...
        Contract directory cache refresh complete
        *   Service uri:  [05/25/2008 23:00:09][http://stylistic:50000/directory]
        *   Service uri:  [05/25/2008 23:00:09][http://stylistic:50000/constructor/1bfa6
        50c-13ef-4966-97b6-9e82d4cf6e17]
        *   No initial manifest supplied. [05/25/2008 23:00:11][http://stylistic:50000/manifestloaderclient]
    Made a new browser window and connected to localhost as localhost\chatt, pw: admin.
    --window is blank.
    Also tried http://stylistic:50000/ with the same result.

     

    Thanks,

    Peter

    Monday, May 26, 2008 3:23 AM
  • Do you have Visual Studio installed? You can use the Visual C# Express Edition which is free. It won't be much use having MRDS without Visual Studio. Unfortunately, for proper integration of MRDS and VS you should install VS first and then MRDS.

     

    You do not need Ageia or DirectX to run a basic DSS node, so they cannot be part of the problem in this particular case. They might be a problem with simulation, but running dsshost does not start the simulator.

     

    You should not have to log in to connect to dsshost with a web browser. Please look at the following page this talks about security for MRDS if you are not an Administrator on the machine:

    http://channel9.msdn.com/wiki/default.aspx/Channel9.SecurityFAQ

     

    Apart from that I am running out of ideas. Is this your personal machine or does it belong to your organization? I am wondering if it might be locked down somehow or if the browser settings have been customized.

     

    Trevor

     

    Monday, May 26, 2008 12:38 PM
  • Trevor,

     

    I have the following installed:
        Vis Basic 2008 Express - ENU
        vis C++ redist
        SDKs for vis studio 2008 express tools for .net f'work and win32
    .   net f'work 3.5
        directX 9 sdk

    I'm on a private machine using IE7 and I definitely have admin rights.

     

    Peter

     

     

     

     

     

     

    Monday, May 26, 2008 1:43 PM
  • Good news Trevor!

     

    I tried

    http://channel9.msdn.com/wiki/default.aspx/Channel9.SecurityFAQ

    rebooted

    ran dsshost /p:50000 in the dos box

    started a new browser and found http://localhost:50000/ !

    One strange thing was in Resource Diagnostics:

    The XML page cannot be displayed

    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


    The following tags were not closed: iBig Smileiagnostics. Error processing resource 'http://localhost:50000/resourcemanager/diagno...

     

    Also there were no users specified under Security Mgr

     

    Thanks,

    Peter

     

     

    Monday, May 26, 2008 3:06 PM
  • I'm having same type problem! mrs 1.5 dss runs with no errors, but when trying http://localhost:50000 to log on using ie7 put in usser name and password and comes up forbidden 403 error. Reinstalled directx sdk.  no help. Should I try reloading something else?

     

     

    Have loaded mrs 1.5

                      mrds 2008

                      mvc# 2008 expr

                      mvwd 2008 expr

                      xp sp2

     

    Thanks Sparktom

     

    Tuesday, May 27, 2008 8:43 AM
  • Did you add localhost to your trusted sites?

    Tuesday, May 27, 2008 4:43 PM
  • Yes tried adding localhost to trusted sites!

    I even shut off guest user.

    Added password to admin. which never had before just to try, never had before installing programs. Rebooted more than once.

    Still get the 403 forbidden.

     

    Sparktom

    Tuesday, May 27, 2008 6:16 PM
  • Found the problem !!!!

    Added http://localhost    to Local intarnet instead of trusted sites.

    That was the fix for me. Simple little errors are costly. Lost lot of time scratching head on that one!

    Hope this helps someone else!

     

    sparktom

    Tuesday, May 27, 2008 6:39 PM
  • Great! I'm glad that both of you now have it working.

     

    Sure, the simple little things are the most annoying. Unfortunately, everybody has a different machine configuration and it is really hard to cover all of the possible combinations.

     

    Peter --

    I am not sure what is happening with the Resource Diagnostics. It works for me using exactly the steps I gave you. As for the Security Manager, you don't need any users in the list.

     

    I hope you both enjoy working with Robotics Studio.

     

    Trevor

     

     

    Thursday, May 29, 2008 12:10 AM