locked
Error while logging into account in Visual Studio RRS feed

  • Question

  • User18287 posted

    I am trying to create a new "HelloWorld" iOS app with Visual Studio. I get the following error in my output window when trying to log in. I can log in through Xamarin Studio, but not Visual Studio.

    Mono.IOS.VisualStudio.MonoTouchPackage Warning: 0 : Initializing Mono.IOS.VisualStudio.MonoTouchPackage Mono.IOS.VisualStudio.MonoTouchPackage Warning: 0 : Activation Check Mono.VisualStudio.Shell.ShellPackage Error: 0 : Failed to load MonoTouch entitlements: Invalid entitlements

    Mono.IOS.VisualStudio.MonoTouchPackage Warning: 0 : Trial Ended : False. Start Upgrade : True. Start Expired : False. Start Invalid : False. Business Features : True. Mono.IOS.VisualStudio.MonoTouchPackage Warning: 0 : Starting Upgrade Workflow Mono.VisualStudio.Shell.ShellPackage Error: 0 : Error while logging into the Xamarin Account System.ComponentModel.Win32Exception (0x80004005): Class not registered at System.Diagnostics.Process.StartWithShellExecuteEx(ProcessStartInfo startInfo) at System.Diagnostics.Process.Start() at System.Diagnostics.Process.Start(ProcessStartInfo startInfo) at Xamarin.Components.Ide.Accounts.AccountService.<>cDisplayClass3.b1(Task1 t) at System.Threading.Tasks.ContinuationResultTaskFromResultTask2.InnerInvoke() at System.Threading.Tasks.Task.Execute() Mono.VisualStudio.Shell.ShellPackage Error: 0 : There was an error while logging into your account

    Mono.IOS.VisualStudio.Utilities.ErrorReportManager Error: 0 : Xamarin.iOS encountered the following error(s): Mono.IOS.VisualStudio.Utilities.ErrorReportManager Error: 0 : Activation incomplete (Generic) You will not be able to load any Xamarin.iOS projects until your license has been activated.

    Once you activate, please re-load this project from the Solution Explorer.

    Monday, July 22, 2013 3:57 PM

All replies

  • User9 posted

    Hey Shawn,

    It looks like you're running into the following issue: http://forums.xamarin.com/discussion/3048/visual-studio-2012-sync-error - is it possible to try the workaround mentioned on there?

    ChrisNTR

    Tuesday, July 23, 2013 9:59 PM
  • User18287 posted

    Thanks for the Reply! I launch Visual Studio as Admin, what else would be required for UAC?

    Tuesday, July 23, 2013 11:18 PM
  • User9 posted

    Did you see the Chrome bug report here: https://code.google.com/p/chromium/issues/detail?id=156400 - that seems to generally be the issue here rather than a UAC issue, does that sound more likely?

    Thursday, July 25, 2013 4:22 PM
  • User18287 posted

    Changed default browser to IE and it's all butter now! Thanks!

    Thursday, July 25, 2013 4:58 PM