locked
Topoedit error: Topoedit.exe is not a valid win32 application RRS feed

  • Question

  • Hi,

    I have recently downloaded and installed the Windows SDK to start some Windows desktop media application development. If it helps give context for an answer, I only have Windows 7 so I downloaded that version of the software, not the latest Windows 8 version.

    To get things started I wanted to experiment with building some topologies using Topoedit. However, when I tried to run the application the following error message immediately appeared: Topoedit.exe is not a valid win32 application. Consequently I could not use it. None of the different topoedit versions (for different architectures as well) that downloaded with the SDK worked. I did however manage to use graphedit.exe ok, but I would still like to validate my topology in topoedit.

    So my question is: How can I fix my error so that I can use topoedit? Also, is it strictly necessary to use topoedit if I can still get graphedit to work, will it have an impact on my application design / debugging capabilities?

    Thanks in advance.

    Saturday, July 26, 2014 7:55 PM

All replies

  • Hello,

    It's the same for, did you found a solution? Thanks

    Thursday, June 18, 2015 3:25 PM
  • It is "by design". Windows 10 TopoEdit is not supposed to work on Windows 7. You should use TopoEdit from the previous SDK release.
    Tuesday, June 23, 2015 9:57 PM