locked
Method Not Allowed (405) RRS feed

  • Question

  • Following the production upgrade this weekend, I have been getting the "Method Not Allowed" error when using the AdCenter API. This happens on any call. We are using Java/Apache Axis implementation on v2. The url we are using is https://adcenterapi.microsoft.com.
    Thursday, October 12, 2006 5:37 PM

Answers

All replies

  • The URL for v2 is https://adcenterapi.microsoft.com/v2/ and for v3 it is https://adcenterapi.microsoft.com/v3/.

    V1 is not supported anymore.

    If this is still not working for you, it sounds like you should escalate this thru our support system, because they will ask for your username/password/access key details, which you cannot share here...

    Shai

    Thursday, October 12, 2006 6:28 PM
  • When you say the url is https://adcenterapi.microsoft.com/v2/, does that mean I should be doing the following:
    new CampaignManagementLocator().getCampaignManagementSoap(new URL("https://adcenterapi.microsoft.com/v2/')?

    I have been using https://adcenterapi.microsoft.com as the url prior to this week and that was working fine. I have already been in contact with your support system and they have been unhelpful so far. That is why I am posting on the forum in case anyone in the community has run into this situation and solved it.
    Thursday, October 12, 2006 6:41 PM
  • Hello,

     

    The proper URL to use for Campaign Management is: https://adcenterapi.microsoft.com/v2/CampaignManagement/CampaignManagement.asmx

     

    Additionally, I reccomend that you become a regular on our AdCenter Developer Blog site, which keeps everyone up-to-date on new features, important announcements and interesting ways to code against our web services: http://adcenterdev.spaces.live.com/

     

    Please feel free to contact me should you have any further questions or comments;  or if I can be of assistance in any other way.

     

    Best Regards,

     

    JasonDT - MSFT

    Thursday, October 12, 2006 8:54 PM
  • Thank you. That seems to fix the problem. I had not been doing that for v2 and it was working fine last week. I wonder why that was. Anyway, I only wish I could get answers so quickly and concisely from your email tech support.

    Thanks,
    Luke
    Thursday, October 12, 2006 9:15 PM
  • I'm glad it worked for you.

     

    BTW: I am part of the Email Tech Support. I'm sorry to hear that your experience has not been optimal. Would you please send me an email (Jason.Dujardin-Terry@microsoft.com) and elaborate on your experience? I've committed to providing the best possible support experience to our customers that I can deliver.

    I appreciate your contribution  to our forums! :-)

     

    Best Regards,

     

    JasonDT - MSFT

     

    Thursday, October 12, 2006 9:33 PM
  • V1 was deprecated during the weekend... it was anounced on our dev blog and via email to API customers registered with Connect.

    Anyway, the latest WSDL version is V3, so I suggest you upgrade to it. V2 will be deprecated on January 7, 2007.

    HTH,

    Shai

    Friday, October 13, 2006 4:10 AM