locked
VS2008 doesn't debug on my new win7 x64, just warns and exits sub. RRS feed

  • Question

  • I have just installed VS2008 on windows 7 enterprise 64 bit (before i just used xp pro 32bit) and now i don't get any errors when debuggin/testing my programs in visual studio. It just throws a warning an exits the sub where the error is in.

    Anybody can give me a hint to where this should be set?

    It worked perfectly out of the box in xp, but now i makes this instead.

    Thursday, January 27, 2011 2:29 PM

Answers

  • Hi Dan Mikkelsen,

    Thanks for your post.

    First, there are several things I would like to clarify with you:

    • Would you please provide more informatio about the error "It just throws a warning an exits the sub where the error is in."? What is the error message?
    • Are you developing a 32 bit application?

    If you are developing a 32bit application, please set the debug Platform to x86.

    I hope this will help.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Andrew.Wu Thursday, February 3, 2011 8:23 AM
    Monday, January 31, 2011 9:24 AM

All replies

  • What edition of VS 2008? Please read the Installation section here:

    http://support.microsoft.com/kb/957912

     

    Thursday, January 27, 2011 3:22 PM
  • Hi Dan Mikkelsen,

    Thanks for your post.

    First, there are several things I would like to clarify with you:

    • Would you please provide more informatio about the error "It just throws a warning an exits the sub where the error is in."? What is the error message?
    • Are you developing a 32 bit application?

    If you are developing a 32bit application, please set the debug Platform to x86.

    I hope this will help.

    Best Regards,


    Andrew Wu [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Andrew.Wu Thursday, February 3, 2011 8:23 AM
    Monday, January 31, 2011 9:24 AM