none
Alert firing that no longer exists RRS feed

  • Question

  • I keep getting notifications for this alert:

    /subscriptions/******-****-****-****-******/resourcegroups/ExcelWraps-Staging/providers/Microsoft.Insights/metricAlerts/DTU%20consumption%20over%2095%20percent%20excelwrapsstaging

    However the alert does not exist and hasn't for a while. How do I delete this aler. If I click the link 'view in portal' which directs to https://azure.microsoft.com/email/?destination=https%3A%2F%2Fportal.azure.com%2F%23blade%2FMicrosoft_Azure_Monitoring%2FUpdateVNextAlertRuleBlade%2FruleInputs%2F%257B%2522alertId%2522%253A%2522%252Fsubscriptions%252F15ed030e-195f-4fc0-bbb9-cfcf581a1c00%252Fresourcegroups%252FExcelWraps-Staging%252Fproviders%252FMicrosoft.Insights%252FmetricAlerts%252FDTU%252520consumption%252520over%25252095%252520percent%252520excelwrapsstaging%2522%257D&p=bT04NDM2MDE4OS1jZDIyLTQ1NGUtOGJjZS02MjM2YmI4NmEzOGUmcz0xNWVkMDMwZS0xOTVmLTRmYzAtYmJiOS1jZmNmNTgxYTFjMDAmdT1hZW8mbD1wb3J0YWwlM0FydWxlLWlucHV0cw%3D%3D

    I get not found. Please make the annoyance go away!

    Thanks,

    John


    Wednesday, June 19, 2019 7:17 AM

Answers

  • The resolution was for me to contact Microsoft support and they deleted the offending alert (which they did for free even though we don't purchase a support package from them)
    • Marked as answer by JohnStaveley Thursday, August 15, 2019 10:28 AM
    Thursday, August 15, 2019 10:28 AM

All replies

  • John,

    First of all, thank you for using Application Insights.  We're in the process of transitioning to new alerts and although uncommon, there have been a few reports of alerts that are not correctly being deleted.

    If you were able to see the alert, this is how you would go about deleting it:

    https://docs.microsoft.com/en-us/azure/azure-monitor/platform/alerts-metric#with-azure-cli

    az monitor metrics alert delete -g {ResourceGroup} -n {AlertRuleName}

    Since you are unable to see the alert you are still receiving notifications from, we will need to get some more information from you.  Please email the following to AzCommunity@microsoft.com and we'll get back to you promptly:

     

    • Your Subscription ID (this can be found by searching for "Subscriptions" in the portal)
    • A link to this thread so we can validate and expedite the request
    • A brief, 2-3 sentence summary of your issue
    • The person you were working with (kobulloc)

     

    That would look something like this:

     

    I was working with kobulloc on an Application Insights issue where I received alerts that no longer showed in the portal.

     

    Forum Link:

    https://social.msdn.microsoft.com/Forums/en-US/8205fff2-77fe-4ed6-9ea8-3cc84bc89b87/alert-firing-that-no-longer-exists?forum=ApplicationInsights

     

    Subscription ID:

    aaaaaa-bbbb-cccc-1111-222222222222

    Thursday, June 20, 2019 4:09 AM
    Moderator
  • Thanks. I have now done this
    Friday, June 21, 2019 10:59 AM
  • Thank you, John!  We've replied to your email and will continue troubleshooting as we get additional information for you.  If you get the chance, we’d really appreciate an update in the forums with your resolution.
    Friday, June 21, 2019 8:41 PM
    Moderator
  • The resolution was for me to contact Microsoft support and they deleted the offending alert (which they did for free even though we don't purchase a support package from them)
    • Marked as answer by JohnStaveley Thursday, August 15, 2019 10:28 AM
    Thursday, August 15, 2019 10:28 AM
  • Thank you for the update, John!  It's possible for settings to get into an undesirable state during these transitions and at times we need to manually remedy the issue.  I'm happy to hear that everything worked out!
    Friday, August 16, 2019 12:01 AM
    Moderator