none
Disable the AltGR+E shortcut in Word. RRS feed

  • Question

  • Hello World! :)

    I need:

    I need to disable the AltGr + E shortcut (makes a euro-sign) in word, and resign the shortcut to a specific macro instead (so it runs a macro).

    I tried:

    I tried the following without succes:

    (1) - Tried to find the shortcut in File>Options>Customize Ribbon>Customize. But there is no euro-sign listed here.

    (2) - Tried to find VBA code for disabling the shortcut, but have not found the "wdKey"- for AltGr. I read some place that AltGr = Ctrl+Alt. But the command Ctrl + Alt + E do not make a euro-sign.

    I am on a danish keyboard by the way.

    Thanks in advance!

    Anders Holm

    Tuesday, June 18, 2013 3:07 PM

All replies

  • Hi Anders

    If I start with the steps you list in (1), select a macro, then press AltGr+E then I see that the shortcut is assigned to the Euro symbol. If I then click "Assign" it reassigns the shortcut to the macro.


    Cindy Meister, VSTO/Word MVP, my blog

    Tuesday, June 18, 2013 3:59 PM
    Moderator
  • Thank you for replying Cindy.

    When I am recording a macro and press "AltGr + E" the macro code is:

    Sub Macro1()
    '
    ' Macro1 Macro
    '
    '
        Selection.TypeText Text:="€"
    End Sub

    So the command "AltGr + E" = "€".

    If I try to change assign the shortcut to another macro under: File>Options>Customize Ribbon>Customize - When I press AltGr+E - The registered command is Alt+Ctrl+E (not "AltGr+E"). The command "Alt+Ctrl+E" is there currently assigned to "€".

    And even that I assign Alt+Ctrl+E to another macro in the "customize"-option - The command AltGr+E anyways makes a "€" (It do not runs the macro like its assigned to)!!!

    What to do???

    Tuesday, June 18, 2013 4:39 PM
  • I see what you mean...

    I don't think there's any way to do this using VBA. The AltGr key is not on a US keyboard; Windows and Office are basically US-centric. All the things we use AltGr for here in Europe don't exist in the USA or are assigned to "normal" key combination. So VBA doesn't give us any access to AltGr.

    It might be possible using the Windows API and a keyboard hook, but it may be simpler to reassign to a different key combination, instead?


    Cindy Meister, VSTO/Word MVP, my blog

    Thursday, June 20, 2013 10:18 AM
    Moderator
  • Is Microsoft really this US-centric !? - Is there not anyone, who can make this work?
    Friday, June 21, 2013 11:33 AM
  • I'm in Word 2013. Checked the entire shortcut menu and there's no way to disable €!!!

    I got to disable every Ctrl + Alt shortcut, after 30 minutes of scrolling. But there's no way to disable the € symbol, there's no entry at all of either  AltGr + E or Ctrl + Alt + E

    ® and ™ were on the common symbols menu, but there's nowhere to find 

    Monday, October 14, 2019 3:07 PM
  • Just go to Insert -> Symbols -> more symbols and there it can be disabled
    • Proposed as answer by Nico_0 Monday, October 14, 2019 3:29 PM
    Monday, October 14, 2019 3:28 PM
  • How?

    Peter Jamieson

    Monday, October 14, 2019 6:45 PM
  • I don't think the situation has changed since Cindy Meister's post in 2013. 

    Deep down, the problem seems to be that Word deals with Windows keystrokes at two different "levels" - when you you are in the dialog that lets you reassign keystrokes, Word "sees" AltGr-E and AltGr-4 as ctrl-alt-E and ctrl-alt-4, so you never actually get to reassign AltGr-E or Alt-Gr-4.

    Peter Jamieson

    Monday, October 14, 2019 6:50 PM