locked
IE9 beta prompts user to download Citrix ICA file RRS feed

  • Question

  • When retrieving a Citrix .ica file, IE9 beta prompts the user (in the notification area), e.g., "Do you want to open or save launch.ica (1.39KB) from 10.70.177.130"?

    With IE8 such files launched automatically (no prompts). Is there a way to avoid the user being prompted in IE9?

    The HTTP request and response are as follows:

    Request:

    GET /Citrix/XenApp/site/launch.ica?CTX_Application=Citrix.MPS.App.Farm1.Notepad&CTX_AppFriendlyNameURLENcoded=Notepad&CTX_Token=DD8B497B48D47C8D627CBDFB50FEBCD5&LaunchId=1286385157450 HTTP/1.1
    Accept: text/html, application/xhtml+xml, */*
    Referer: http://10.70.177.130:8000/Citrix/XenApp/site/default.aspx
    Accept-Language: en-GB
    User-Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0)
    Accept-Encoding: gzip, deflate
    Host: 10.70.177.130:8000
    Connection: Keep-Alive
    Cookie: WIUser="CTX_ForcedClient#Off~CTX_LaunchMethod#Ica-Local~CTX_AuthMethod#Explicit~CTX_ViewStyle#%7bApplications%3dIcons%7d"; WINGDevice="CTX_DeviceId#WI_kCKb7pITR80Ay9cEr"; WINGSession="icaScreenResolution#1280x1024~CTX_LogonType#Explicit~streamingClientDetected#~clientConnSecure#false~remoteClientDetected#Ica-Local%3dAuto%2cIncorrectZone~icoStatus#IsNotPassthrough"; WIAuthId=ADC58A5E26A6471BFFDB00AEF4A7278C; ASP.NET_SessionId=ufwytz55wscpqt45gxx2b445

    Response:

    HTTP/1.1 200 OK
    Cache-Control: private
    Content-Length: 1432
    Content-Type: application/x-ica
    Expires: Wed, 29 Sep 2010 18:32:40 GMT
    Server: Microsoft-IIS/7.5
    Set-Cookie: WINGSession="CTX_LogonType#Explicit~icaScreenResolution#1280x1024~streamingClientDetected#~clientConnSecure#false~remoteClientDetected#Ica-Local%3dAuto%2cIncorrectZone~icoStatus#IsNotPassthrough"; path=/Citrix/XenApp/; HttpOnly
    Set-Cookie: WIUser="CTX_ForcedClient#Off~CTX_LaunchMethod#Ica-Local~CTX_AuthMethod#Explicit~CTX_ViewStyle#%7bApplications%3dIcons%7d"; expires=Thu, 06-Oct-2011 17:12:40 GMT; path=/Citrix/XenApp/; HttpOnly
    Set-Cookie: WINGDevice="CTX_DeviceId#WI_kCKb7pITR80Ay9cEr"; expires=Thu, 06-Oct-2011 17:12:40 GMT; path=/Citrix/XenApp/; HttpOnly
    Date: Wed, 06 Oct 2010 17:12:40 GMT

    [Encoding]
    InputEncoding=UTF8

    [WFClient]
    CPMAllowed=On
    ProxyFavorIEConnectionSetting=Yes
    <rest of .ica file deleted for brevity>

     

    .ica files are registered with the system to launch with the Citrix ICA client. The launch occurred automatically in IE8 on the very same Win7 client machine prior to installing IE9 beta.

    Thanks,

    John.

    Wednesday, October 6, 2010 5:26 PM

Answers

  • Thanks for the response, but the user agent string is not the cause. I've tried all the various combinations but still get the same behaviour. IE9 refuses to auto-launch based on the content-type in the HTTP response. I've submitted a ticket at connect, as you suggested.

     

    John.

     

    • Marked as answer by Yanping Wang Wednesday, October 13, 2010 9:35 AM
    Thursday, October 7, 2010 9:58 AM

All replies

  • Hi John,

    Probably the IE9 UAS is the cause....

    Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; Trident/5.0)

    I'm not a citrix user/supporter/expert, so I can only guess.

    Try adding your server's domain to the Compatibility View List to force IE9 to send the IE7 UAS.

    or

    Use the Developer Tool (F12)>Tools>Change User Agent String>IE8

    We are volunteers here. connect.microsoft.com/ie is the feedback portal for IE9 Beta. In the first instance report all issues there.

    However if the above suggestion works or you find your own workaround, submit a ticket at connect with the workaround for the benefit of the IETeam and other citrix users/administrators.

     

     


    Rob^_^
    Wednesday, October 6, 2010 6:33 PM
  • Thanks for the response, but the user agent string is not the cause. I've tried all the various combinations but still get the same behaviour. IE9 refuses to auto-launch based on the content-type in the HTTP response. I've submitted a ticket at connect, as you suggested.

     

    John.

     

    • Marked as answer by Yanping Wang Wednesday, October 13, 2010 9:35 AM
    Thursday, October 7, 2010 9:58 AM
  • Did you solve this problems?

    I didn't find a solution, and I am considering to downgrade to IE8

    Tuesday, March 15, 2011 7:55 PM
  • Any news on this one, now the new IE has been launched many Citrix customers would like to use it but still keep failing when they go to their webinterface from out IE9. The system knows what to do with the launch.ica BUT after IE9 is installed they first have to save it and then launch it, this isn't quite a nice feature.
    Thursday, March 17, 2011 9:35 PM
  • ive seen this behaviour with the RTM version of the client aswell;

    http://forums.citrix.com/thread.jspa?threadID=283995&tstart=0

    Monday, March 21, 2011 8:20 AM
  • Hello All

    I've picked this up and asked for some investigation.

    Will be back in touch as soon as I can.

     

    Regards

    Mark Feetham
    Senior Program Manager | Internet Explorer Product Quality

    Wednesday, March 23, 2011 9:30 PM
  • Hi,

    We also have problems with this.

    Its actually 2 problems in one.
    First off you get this "open or save" window everytime, instead of just opening the citrix application directly.
    Then there is that the .ica file download when pressed 'open' or even 'save' will not complete.

    It "freeze" on 100% and the file becomes a launch.ica.partial which is not possible to execute. There are two similar ways to get past this, and that is by either restarting IE9, then log into the webinterface again so you become authenticated, then go into 'view downloads' and now the launch.ica file can be resumed and opened. But if you do not log into the webinterface beforehand it will fail, understandably.
    Or you can cancel the download (which is at 100% anyway) and then rename the launch.ica.partial file to just launch.ica from windows explorer, and then execute it.
    Since not everyone seems to have this problem, im guessing this might be a IE security setting or something.

    So I am looking forward to a answer/solution from MS for this :)
    Please keep us updated Mark!

    Regards
    Peter

    Friday, March 25, 2011 8:25 AM
  • We are experiencing the same problem. IE9 and Citrix Online Plugin 12.1.0.30 (admin). Oddly enough, my first Win7 X64 Pro Build worked without issue once I put the IWI into trusted sites. Subsequent builds all experience the same problem. With IE 9 x64, the prompt still occurs but open will launch the ICA session. With the x86 version, launch.ica just gets stuck in the downloads as described above.

    PN agent works fine, and auto launch works great with Mozilla and IE7, IE8.

    Hopefully we get some resolution to this soon!

     

    Thanks,

    Dave

    Thursday, March 31, 2011 2:05 PM
  • I have the same symptoms as well even after putting the IWI into trusted sites.  I have to resume the download for it to work.  For one site, the download appears in the 'view downloads' list right away with a clickable resume button.  Another site, I see nothing in the 'view downloads' list until I exit IE9 then come back to the site.

    Ditto on 'hopefully we get some resolution to this soon' !!

    Regards,

    Kathy

    Thursday, March 31, 2011 5:01 PM
  • Hi all

    Speaking with my colleagues. We've seen similar reports across multiple versions of IE for the initial issue report i.e. prompting for download instead of launching. Please can you take a look at this thread on the Citrix Forum (summary disable IE option 'Do not save encrypted pages to disk' http://forums.citrix.com/message.jspa?messageID=307964. Also as Kathy points out confirm that the site is in the Trusted Sites list.

    For partial downloads. Can you clear the downloads and clear the cache (temp files etc). If that doesn't do it can we next try Reset Internet Explorer Settings.

    And are we all on RTM version?

    Await your feedback before next steps.

    Thanks

    Mark Feetham

    Thursday, March 31, 2011 9:13 PM
  • IE9 is officially unsupported as per the final posting in the the Citrix Forum:

    http://forums.citrix.com/thread.jspa?threadID=283995&start=15&tstart=0

    Friday, April 1, 2011 12:55 AM
  • Hi,

    1. "Do not save encrypted pages to disk" is not active.
    2. The site is in the "Trusted Sites" list.
    3. Cleared the entire cache (temp files etc).
    4. Did a IE reset.
    5. Version of IE9 is the RTM.

    We still have the same problem as mentioned in my post above.

    Regards
    Peter

    Friday, April 1, 2011 7:27 AM
  • Thanks fsk10 - our investiation continues.
    Friday, April 1, 2011 6:04 PM
  • I decided to test ie9 yesterday and after installing it and seeing all the great things that you can now do with it i was happy. then i decided to check a web page that renders great in ie8, fire fox and chrome. the page is here http://echoes.net63.net/video.php?p=177 you should click on a playlis then click on a episode and then you can play the video that will be linked there. unfortunatly ie9 for some reason is doing one of two things either it is not registering that i clicked on the links( i dont think that is the problem) or there is a bug that is conflicting with projekktor. needless to say i am a bit disappointed with this i would think that if ie8 could display and play the vieo then ie9 would have no problems either. anyway i am not here to harp on MS about ie9 just to let you guys know of a bug i found and hopefully you will rectify it soon. i have also noticed that gradients with css are a little buggy atleast on my machine (win 7 64 bit) some times they work sometimes not( ?). Thanks
    jeevanSathi
    Saturday, April 2, 2011 5:22 PM
  • I had the exact same after upgrading to IE9. IE9 was asking for save or open launch.ica but nothing happened.

    Everything resloved via tools, internet options, security, trusted sites

    added citrix domain to trusted sites and uncheck Enable protected mode.

     

    by the way I am pretty sure I had our citrix server in trusted sites prior upgrade to IE9

    Sunday, April 3, 2011 9:41 AM
  • Thanks fsk10 - our investiation continues.


    Any news on this matter Mark?

    Regards
    Peter

    Wednesday, April 13, 2011 11:40 AM
  • Have been testing this issue and here have been my results:

     

    IE9 Installed - Websites added to Trusted Sites

    XenApp Client: 11.X

    WI 4.X = Prompts for file download. Download does not complete.

    WI 5.X =  Nothing happens - No prompt for file download.

     

    XenApp Client: 12.1

    WI 4.X = Prompts for file download. Download does not complete.

    WI 5.X =  Applications launch normally.

     

    So if you are running a newer version of WI hopefully a client upgrade should help with the issue.

    Thursday, April 14, 2011 8:34 PM
  • Hi All,

    Having the same issues as stated above whereby IE9 requests the file be saved / opened and then fails. I had no joy in renaming the file, although there were occasions when the resume download function was available, once clicked this would load the application.

    I decided to rollback to IE8 which works as expected. I will move forward to IE9 once this fault has been corrected.

     

    • Proposed as answer by man4 Wednesday, April 27, 2011 2:54 PM
    Tuesday, April 26, 2011 2:11 PM
  • Please try the steps to rename the registry key in http://support.citrix.com/article/CTX129082

    This should fix the issue...

    • Proposed as answer by man4 Wednesday, April 27, 2011 3:00 PM
    Wednesday, April 27, 2011 2:57 PM
  • Sorry for the delay. Yes man4 has posted a link to a Citrix Support Article. Microsoft Technical Support reviewed and confirmed that with the site in a zone using medium-low secuirty template *and* the change to the reg key will open without prompting. Renaming the key with the site in Internet or Trusted sites zone (Medium security Template) will give you the Open option in the Download manager instead of immediately launching the .ica in the Citrix client. To save you looking further in the thread here's the link

    http://support.citrix.com/article/CTX129082

    Wednesday, April 27, 2011 10:47 PM
  • Adding the site to Trusted Sites and de-selecting the ActiveX Filtering worked for me.

    Thanks!

    Kathy

    Tuesday, May 31, 2011 5:57 PM
  • I have dropped the security to medium low, added the site to trusted sites, checked all the other options and still having an issue according to the above link I should rename the regkey I can find the key but not sure exactly what to rename it to

     

    Disable the MIME filter: by renaming the following registry key: HKEY_CLASSES_ROOT\PROTOCOLS\Filter\application/x-ica

    • Proposed as answer by RedStef Wednesday, July 20, 2011 1:54 PM
    • Unproposed as answer by RedStef Wednesday, July 20, 2011 1:56 PM
    Tuesday, June 7, 2011 3:40 AM
  • Go to the browser (IE) internet Options on the workstation, Advanced & untick "Do not save encrypted pages to disk" option under security. That will resolve the issue.
    Then execute this: c:\Program Files (x86)\Citrix\ICA Client\wfica32 /setup

     

    This worked for me!

    Friday, June 17, 2011 10:17 AM
  • I renamed the file to "test", restarted my browser, logged back in to Citrix and it worked fine.  I still received the "open or save" dialogue but after selecting open, a few seconds passed and the authentication began :)  Worth a shot!  I renamed the second file, not the "(Default)" as that doesn't give you an option to rename anyways.  Good luck!
    Wednesday, July 20, 2011 1:56 PM