locked
HTTP Error 404.17 - Not Found RRS feed

  • Question

  • User1289807499 posted

    Hey everyone,

    i've been struggling with this issue for 2 days now. i have a web applicatin asp.net, a webservice using WCF, and data model using XPO ( eXperience persistent Object )

    I've created the virtual directory for the web application, wrote code for my webservice, retrieved data from my SQL server to the data model but when i browse my webservice (.svc file ) i got the 404.17 error


    for the pool applications, i'm using Default app pool 

    i'm using II8, Windows 8, VS2010, SQL SERVER 2010 Express. 

    could someone tell me what to do ? Thanks

    By the way, i'm working in a group of 3 developpers and all of them had deployed the webservice with no prob eventough we have the same code !

    Wednesday, April 3, 2013 4:59 PM

Answers

  • User381600086 posted

    As developer we always have wrong notion of saying same code. Sometimes environment and configuration settings also plays an essential role. To better understand the scenario, please check the Httpsys Error log or event viewer for more information. IIS 8 also displays complete set of error .It would be helpful if you flash complete error.

    1) Check App pool settings and compare with your fellow developer.

    2) Verify Apppoolidentity.

    3) Check web.config permission. If it is local I suggest give everyone rights to your virtual directory or website

    4) Try to enable Directory browsing and set default Document.

    5) Check solution is built properly.

    404.12 represents request filtering in IIS7.5 in IIS6.0 we used to have URLscan. Check any filtering conditions has been set.

    refer

    http://www.iis.net/configreference/system.webserver/security/requestfiltering

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, April 3, 2013 6:26 PM
  • User-1662538993 posted

    You can do that by going to iis and just click on the web service you have hosted. on right make sure you have features view enabled and then you can see directory browsing and default document.

    You can enable directory browsing and then you can set default document as your svc file.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 4, 2013 8:48 AM

All replies

  • User-1137493631 posted

    did you deployed in the same machine or other machine ? the problem could be your solution file , did you change the compilation mode something like x86 ?

    any how please try this site

    http://forums.iis.net/t/1160143.aspx

    Wednesday, April 3, 2013 5:47 PM
  • User1289807499 posted

    Thank you for your answer but, No, i'm developping the solution with my own machine 32 bits.. 

    Wednesday, April 3, 2013 6:15 PM
  • User381600086 posted

    As developer we always have wrong notion of saying same code. Sometimes environment and configuration settings also plays an essential role. To better understand the scenario, please check the Httpsys Error log or event viewer for more information. IIS 8 also displays complete set of error .It would be helpful if you flash complete error.

    1) Check App pool settings and compare with your fellow developer.

    2) Verify Apppoolidentity.

    3) Check web.config permission. If it is local I suggest give everyone rights to your virtual directory or website

    4) Try to enable Directory browsing and set default Document.

    5) Check solution is built properly.

    404.12 represents request filtering in IIS7.5 in IIS6.0 we used to have URLscan. Check any filtering conditions has been set.

    refer

    http://www.iis.net/configreference/system.webserver/security/requestfiltering

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, April 3, 2013 6:26 PM
  • User1289807499 posted

    Thank you for reading Santosh. 

    for the apppool i'm using the DefaultAppPool, AppPoolIdentity for the identity, and my solution is deployed with the DefaultAppPool.

    for the fourth suggestion, i don't know to check or maybe didnt understand it. could you please clarify this suggestion :)

     

     

    Wednesday, April 3, 2013 7:04 PM
  • User-1662538993 posted

    You can do that by going to iis and just click on the web service you have hosted. on right make sure you have features view enabled and then you can see directory browsing and default document.

    You can enable directory browsing and then you can set default document as your svc file.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, April 4, 2013 8:48 AM