locked
Installing SNMP Extension agent dll on Windows Server 2008 RRS feed

  • Question

  • I have written a 32 bit SNMP extension agent dll in native C++ (since you have to write it this way).

    This works on a Windows XP machine and a Windows 2003 server machine without any problems.

    I have now installed it on a machine running Windows Server 2008 i.e. 64bit.

    I have added my SNMP agent to the following registry location (which is a different location to that used on the 32 bit versions):

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\SNMP\Parameters\ExtensionAgents

    My entry under this key references another registry location which has a Pathname entry which is set to "d:\test\PP.PixelPromo.Support.SnmpAgent.dll" as a REG_EXPAND_SZ type (as opposed to a REG_SZ type).

    Every time that I start the SNMP service I get the following error in the event log:

    The SNMP Service is ignoring extension agent dll "d:\test\PP.PixelPromo.Support.SnmpAgent.dll" because it is missing or misconfigured.

    I have removed all the code from the SNMP agent dll except the 4 main entry points and even this gives me the error.

    I cannot see anything wrong with the settings that I have made in the registry. This is obviously a 32 bit/64 bit issue but I cannot see what the issue is.

    Can anyone help with this problem?

    Thanks

    Ian

    Tuesday, October 12, 2010 6:20 AM

Answers

All replies

  • Hi Ian,

    First of all, I recommend you double check the KB: How to add an SNMP extension agent to the NT registry.

    As you mentioned, the agent dll is 32bit and the windows is 64Bit Server 2008. A 32bit application will run under wow64 in a 64 bit Windows.  Some register entries are redirected. For example, HKEY_LOCAL_MACHINE\Software is redirected to HKEY_LOCAL_MACHINE\Software\Wow6432Node. This could be a problem when you setup the agent dll (Step 2 in KB). Please double check whether this is in your case. More detail information about wow64 registry redirector, please check: http://msdn.microsoft.com/en-us/library/aa384232(VS.85).aspx

    Regards,
    Yi Feng Li
    MSDN Subscriber Support in Forum
    If you have any feedback of our support, please contact msdnmg@microsoft.com.


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Yi Feng Li Thursday, October 21, 2010 2:16 AM
    Wednesday, October 13, 2010 6:41 AM
  • Hi Ian,

    Would you mind letting me know the result of the suggestions? If you need further assistance, feel free to let me know. I will be more than happy to be of assistance.

    Regards,
    Yi Feng Li
    MSDN Subscriber Support in Forum
    If you have any feedback of our support, please contact msdnmg@microsoft.com.
     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, October 18, 2010 3:14 AM
  • How could the reported issue be a registration problem?

    The error message is s'th like "ignoring .. foo.dll .. because it is missing or misconfigured."

    So the registry entries are found and interpredted by the snmp service. I think we are still searching for a better answer...

    Tuesday, January 4, 2011 9:52 AM
  • Hi,

    I have been working on SNMP traps for past few days, and quite new to this.

    Basically I am looking for a way in which I can use 32 bit agent on Windows 2008 (64-bit).

    I am also having similar issue as mentioned in Ian's first mail, though I didn't try adding SNMP agent in the registry. Could you please elaborate on this a bit.

    Also, would appreciate if some one could let me know if there is any way out to fix the issue. (The error that Ian was talking about after adding agent in the registry), or if there is some other way to use 32 bit agent on Windows 2008 (64-bit).

    Thanks in advance.

    Best Regards,
    Pooja

    Friday, November 11, 2011 1:51 PM