locked
Failed to resolve assembly Xamarin.IOS in Visual Studio RRS feed

  • Question

  • User1278 posted

    This is a somewhat new setup with VS 2017 and a Mac build server. For some reason get the following error when building. I have updated both XS on the mac server and VS on the windows box to the latest version of everything. Any ideas here? THanks!

    Error Failed to resolve assembly: 'Xamarin.iOS, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065' at Mono.Cecil.BaseAssemblyResolver.Resolve(AssemblyNameReference name, ReaderParameters parameters) at Mono.Cecil.DefaultAssemblyResolver.Resolve(AssemblyNameReference name) at Mono.Cecil.MetadataResolver.Resolve(TypeReference type) at Mono.Cecil.TypeReference.Resolve() at Mono.Cecil.Mixin.CheckedResolve(TypeReference self) at Mono.Cecil.SignatureReader.ReadCustomAttributeEnum(TypeReference enumtype) at Mono.Cecil.SignatureReader.ReadCustomAttributeElementValue(TypeReference type) at Mono.Cecil.SignatureReader.ReadCustomAttributeElement(TypeReference type) at Mono.Cecil.SignatureReader.ReadCustomAttributeFixedArgument(TypeReference type) at Mono.Cecil.SignatureReader.ReadCustomAttributeConstructorArguments(CustomAttribute attribute, Collection1 parameters) at Mono.Cecil.MetadataReader.ReadCustomAttributeSignature(CustomAttribute attribute) at Mono.Cecil.CustomAttribute.<Resolve>b__2(CustomAttribute attribute, MetadataReader reader) at Mono.Cecil.ModuleDefinition.Read[TItem,TRet](TItem item, Func3 read) at Mono.Cecil.CustomAttribute.Resolve() at Mono.Cecil.CustomAttribute.getConstructorArguments() at Mono.Cecil.ImmediateModuleReader.ReadCustomAttributes(ICustomAttributeProvider provider) at Mono.Cecil.ImmediateModuleReader.ReadMethods(TypeDefinition type) at Mono.Cecil.ImmediateModuleReader.ReadType(TypeDefinition type) at Mono.Cecil.ImmediateModuleReader.ReadTypes(Collection1 types) at Mono.Cecil.ImmediateModuleReader.ReadModule(ModuleDefinition module) at Mono.Cecil.ModuleWriter.WriteModuleTo(ModuleDefinition module, Stream stream, WriterParameters parameters) at Mono.Cecil.ModuleDefinition.Write(Stream stream, WriterParameters parameters) at Mono.Cecil.ModuleDefinition.Write(String fileName, WriterParameters parameters) at Xamarin.Build.Download.XamarinBuildiOSResourceRestore.MergeResources(IAssemblyResolver resolver, String originalAsmPath, String mergedAsmPath, List1 resourceItems) MineChatForms.iOS

    Wednesday, April 5, 2017 4:07 PM

Answers

  • User245775 posted

    If you have Xamarin studio in mac, open it and check for updates. You will be able to see the components pending for installation in stable channel.

    Try downloading it and install. After which you should be able to connect from visual studio.

    FYI: the latest version for Xamarin.iOS is 10.8.0.175 as of now. Please verify that you have same versions available in both the visual studio in windows as well as the mac

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, April 6, 2017 5:37 AM

All replies

  • User1278 posted

    One thing I notice is that I show Xamarin.iOS version 10.6.0.9 in VS and 10.6.0.10 on Mac server. No idea though how to sync them up as they are both up to date.

    Wednesday, April 5, 2017 4:40 PM
  • User245775 posted

    If you have Xamarin studio in mac, open it and check for updates. You will be able to see the components pending for installation in stable channel.

    Try downloading it and install. After which you should be able to connect from visual studio.

    FYI: the latest version for Xamarin.iOS is 10.8.0.175 as of now. Please verify that you have same versions available in both the visual studio in windows as well as the mac

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, April 6, 2017 5:37 AM
  • User1278 posted

    Ya, I must have something out of wack. I noticed that xcode 8.3 was not installed, so installing that to see if that helps. Thanks.

    Thursday, April 6, 2017 2:16 PM