none
MS Project not able to read queries in vsts RRS feed

  • Question

  • Hi

    I have setup a project in VSTS and would like to synch it with MS Project. This was working last week but now we get the following error when trying to select a query to read from...

    It connects to the server fine, I then select Get Work Items and Saved Query but instead of a list of queries we get...

    Error converting value "Microsoft.Identity.Model.Claims.ClaimsIdentity;....." to type "Microsoft.VisualStudio.Services.Identity.IdentityDescriptor".path'authenticateduser.descriptor', line 1, position 185.

    However if I select IDs or Title contains to query then it works fine. This same issue occurs on both Project 2013 and Project 2016, and as mentioned was working on both previously.

    

    Thanks for any help

    Brian

    PS the same process works fine in Excel.


    Wednesday, April 13, 2016 8:36 AM

All replies

  • Same issue here with Team Foundation Server 2015. Not present with Team Foundation Server 2013

    Don`t know why its been re-categorized under "Project Customization and Programming" as this is an out of the box feature.

    Repro steps:

    1. Create an empty project
    2. Go to the "Team" tab (given that you have the TFS Plugin loaded)
    3. "Choose team project" in the ribbon to connect to your TFS repository
    4. "Get work items" button on the ribbon
    5. Expand the "Saved query" combo box

    Expected result:

    - you should see here all the work item queries available under the repo accessible to current user.

    Actual result:

    - Error is indicated in the combo box

    Error converting value System.Security.Principal.WindowsIdentity to type Microsoft.VisualStudio.Services.Identity.IdentityDescriptor. Path authenticatedUser.descriptor line 1 position 168.

    --------------------------------

    Windows 7

    Microsoft Project 2016 16.00.4266.1003

    TFS Plugins version loaded in memory (ex: Microsoft.TeamFoundation.Client.dll, TFSOfficeAdd-in.dll) 14.95.25118.0

    Visual Studio 2015 Update 2

    Team Foundation Server 2015 Update 2

    ------------------------------

    More info

    Exception thrown: 'System.ArgumentException' in Newtonsoft.Json.dll
    Additional information: Could not cast or convert from System.String to Microsoft.VisualStudio.Services.Identity.IdentityDescriptor.

    Exception thrown: 'Newtonsoft.Json.JsonSerializationException' in Newtonsoft.Json.dll
    Additional information: Error converting value "System.Security.Principal.WindowsIdentity;S-1-5-21-1644491937-1993962763-725345543-7920" to type 'Microsoft.VisualStudio.Services.Identity.IdentityDescriptor'. Path 'authenticatedUser.descriptor', line 1, position 168.

    Thursday, April 14, 2016 7:17 PM
  • Is there an update on this issue?

    Begin after 4/13/16 as that is my last published schedule. Tried logging out/reconnecting but the error persists. 

    Thursday, May 5, 2016 9:41 PM
  • This is a problem for me as well.

    VS online

    Project 2010

    For some reason I was able to get access to my queries for a short time yesterday but after restarting Project the error described above happened again, and has continue to happen.

    This is a huge blocker for me and my team. 

    /J.P.

    Wednesday, May 11, 2016 1:55 PM
  • I was having the similar problem to retrieve work items by queries, but with Project Professional 2016. To work around, I did the following to get it to work with Project Professional 2013:

    1. Uninstall Project Professional 2016.
    2. Uninstall Visio 2016, and another other Office 2016 related applications. 
    3. Install Project Professional 2013. 

    Now, the Project Professional 2013 is able to get work items by queries from Visual Studio Team Services (VSTS), and it also can successfully get work items by queries from on-site TFS 2015 Update 2. It's very unfortunate that I need to give up new features for Project 2016.

    Jack


    • Edited by JackL78 Thursday, May 12, 2016 1:59 AM
    Thursday, May 12, 2016 1:57 AM
  • Have you managed to find a solution for this yet? Other than going back to Project 2013!

    If this is a Project 2016 bug is there any word on a fix?

    All the best,

    Tim

    Saturday, May 21, 2016 1:57 PM
  • Recently it has started working if we first connect and Synch with Excel then open MS Project and the queries are available.


    Thursday, June 2, 2016 7:03 AM
  • This works for me. Thanks for sharing.
    Tuesday, June 14, 2016 9:25 PM
  • I've just resolved exactly this issue by applying the latest project update.

    Running project 16.0.7329.1017 I can now sync project with VSTS


    twitter - @simon_sabin blog - http://www.sqlblogcasts.com/blogs/simons SQLBits - Largest SQL Server Conference in Europe and its free

    Tuesday, October 18, 2016 9:42 AM
  • I am getting this exact same issue, I am on Microsoft Project 2016 Standard 32 bit with the latest Jan 2017 Update applied to project. Please advise?
    Tuesday, February 28, 2017 5:55 PM
  • I used the suggestion below and it worked for me.

    Recently it has started working if we first connect and Synch with Excel then open MS Project and the queries are available.

    Proposed as answer by Luis F. S. Rgoni Thursday, June 30, 2016 1:37 PM
    Thursday, June 02, 2016 7:03 AM




    Tuesday, February 28, 2017 9:32 PM