locked
Playback Error - Replaying steps recorded in IE9 fails in other browsers

    Question

  • I am using MTM and IE9 to record my manual test. When I replay the test in IE9 again, it works perfectly. However, when I open Firefox or Chrome and try to replay that recording, it always fails. According to Microsoft, both Firefox and Chrome are supported when replaying recorded steps. Here's the link to that article: http://msdn.microsoft.com/en-us/library/vstudio/dd380742.aspx. Both Firefox and Chrome are up-to-date. My Visual Studio is version 11.0.60610.01 Update 3, which is also required for this functionality. I seem to have everything in order, but I just can't replay my recordings in other browsers. It tries to execute/replay the first step in my test case, then throws the following error:

    What else am I missing?

    Regards,

    R.P.

    Wednesday, August 21, 2013 7:20 PM

Answers

  • Hi R.P.,

    Thank you for posting in the MSDN forum.

    Actually the content in the MSDN document shared by you means that we record the coded UI test in Chrome/Firefox, and then replay it in the same web browser, it doesn’t mean that we record the test in IE, and then replay it in these browsers.

    As far as I know, the VS IDE doesn’t support this action (record and playback in different browsers) in default. But there is an extension tool “Selenium components for Coded UI Cross Browser Testing”, maybe it is what you want to get.

    Have a nice weekend,


    Jack Zhai[MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    • Marked as answer by roman.peshkov Friday, August 23, 2013 8:45 PM
    Friday, August 23, 2013 2:41 AM
    Moderator

All replies

  • I also noticed that in that error message it says "Unable to find Windows Internet Explorer window..." Could that be my problem? The fact that it's looking specifically for IE window? If that's the case, how can I record it so that it doesn't reference a particular browser?
    Wednesday, August 21, 2013 7:21 PM
  • Sorry, one more update. I tried doing the original recording in Firefox and then replaying it. It doesn't replay it in Firefox. Throws this error:

    Wednesday, August 21, 2013 7:26 PM
  • Hi R.P.,

    Thank you for posting in the MSDN forum.

    Actually the content in the MSDN document shared by you means that we record the coded UI test in Chrome/Firefox, and then replay it in the same web browser, it doesn’t mean that we record the test in IE, and then replay it in these browsers.

    As far as I know, the VS IDE doesn’t support this action (record and playback in different browsers) in default. But there is an extension tool “Selenium components for Coded UI Cross Browser Testing”, maybe it is what you want to get.

    Have a nice weekend,


    Jack Zhai[MSFT]
    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support
    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    • Marked as answer by roman.peshkov Friday, August 23, 2013 8:45 PM
    Friday, August 23, 2013 2:41 AM
    Moderator