none
Windows Azure Support: “Known Issues using RDP file from the Management Portal”

    General discussion

  • Issue 1:

    The Remote Desktop Protocol (RDP) file from the Windows Azure platform management portal does not work in the following mixed version scenario:

    • The VM Role package is packaged with Windows Azure SDK 1.4, but the Windows Azure Integration Components installed in the image are Windows Azure SDK 1.3.

    Cause:
    With the release of SDK 1.4, we removed the requirement to suffix the load balancing cookie with the endpoint name. This is to fix a bug that occurs when the role name is too long and the load balancing cookie does not support it.
    As the portal sees the package is SDK 1.4, it does not add the endpoint name, but the remote component in the image is still SDK1.3, and expects the endpoint name, that’s how it fails.
    This issue occurs in the VM Role, as this mixed version (package and integration components) scenario only happens for VM Role. For Web/Worker role, the components binaries are packed into the package, so they are always of the same version.

    Resolution:
    Option 1: Install SDK 1.4 integration components into the image. This is recommended, as in SDK 1.4, there are other bug fixes that are related to remote desktop.
    Option 2: Manually append the endpoint name in the RDP file.
      a) Open the .rdp file using Notepad
      b) Find the following line at the end of the file LoadBalanceinfo:s:Cookie: mstshash=<RoleName>#<RoleInstanceName>
      c) Modify the line by adding#Microsoft.WindowsAzure.Plugins.RemoteAccess.Rdp at the end 
         LoadBalanceinfo:s:Cookie: mstshash=<RoleName>#<RoleInstanceName>#Microsoft.WindowsAzure.Plugins.RemoteAccess.rdp
           Note: The line must not contain any trailing spaces
      d) Save the .rdp file

     

    Issue 2:

    After performing an in-place upgrade on web and/or worker roles from SDK 1.3 to SDK 1.4, the Remote Desktop Protocol (RDP) file from the Windows Azure platform management portal no longer works.

    Cause:
    The SDK 1.3 bits continue to run when an in-place upgrade is performed despite the SDK 1.4 bits being in the updated package. There is a bug in the logic that detects whether or not the forwarder service is running that causes the 1.4 bits to erroneously detect the 1.3 bits and assume the service is running instead of stopping the 1.3 service and starting the 1.4 version.

    Resolution:
    Option 1: Reboot all instances of the role that contains the <Import moduleName=”RemoteForwarder”/> line in the service definition using the button in the service management portal. This will kill the 1.3 process and when the role restarts, the 1.4 bits will run and the 1.4 .rdp file will work.
    Option 2: Manually append the endpoint name in the RDP file.
      a) Open the .rdp file using Notepad
      b) Find the following line at the end of the file LoadBalanceinfo:s:Cookie: mstshash=<RoleName>#<RoleInstanceName>
      c) Modify the line by adding#Microsoft.WindowsAzure.Plugins.RemoteAccess.Rdp at the end
      LoadBalanceinfo:s:Cookie: mstshash=<RoleName>#<RoleInstanceName>#Microsoft.WindowsAzure.Plugins.RemoteAccess.rdp
        Note: The line must not contain any trailing spaces
      d) Save the .rdp file


    Wednesday, April 13, 2011 6:03 PM
    Moderator

All replies