locked
CPU Usage (Sample) not being shown. RRS feed

  • Question

  • Hi,

    I'm developing a windows driver using Visual Studio and the WDK. Now, I'm in the process of profiling the code to solve some bottlenecks.

    I used the tool Windows Performance Recorder to trace CPU usage. For now I'm only tracing CPU usage only.

    In that machine the item CPU Usage has two items (among others). One is called "CPU Usage (Sampled)" and another called "CPU Usage (Precise)"

    I need to use the sampled version, one reason it allows me to show the stack in a more easy way.

    I have another machine where I debug and install the driver(I don't use the same machine for a number of reasons like debugging). So for doing  the analyzisis I downloaded the stand alone version of the product. But, after tracing the CPU usage the report only contains the "CPU Usage (Precise)", the Sampled version is missing.

    Do you guys know what could be happening? 

    Thanks in advance.

    I attach screen shot of what I see in WPA.


    Martin

    Thursday, January 28, 2016 7:35 PM

All replies

  • its an old post, but is this resolved? i got the same issue...:(
    Thursday, June 23, 2016 6:36 PM
  • I added the answer in the later posting here

    In short, your trace is missing sampled profile events. 1) check out your system for the hardware counter capability and interval, 2)check if other apps uses hardware counters in a way that you can't get the timer counter allocation.


    • Edited by PyoShong Tuesday, April 21, 2020 11:39 PM
    • Proposed as answer by PyoShong Tuesday, April 21, 2020 11:40 PM
    Tuesday, April 21, 2020 11:39 PM