locked
How can I get Sql Server 2008 Express for Visual Studio 2010 Installed? RRS feed

  • Question

  • I have tried everything I can think of or find.
    Nothing works.

    OS is Windows 7 64 bit.

    I installed Visual Studio 2010 Ultimate which installed Sql Server Express.
    When I look at my services it shows SQL Server Express running.

    I click 'Sql Server Installation Center' and then 'Installation' then 'New Sql Server stand-alone installation . . .'
    It tells me 'Browse for Sql Server Installation Media'
    I tried pointing it at the DVD: 'not a valid installation folder'
    I copied the DVD contents (all 2.3 GIGS) to my hard drive and pointed it at that folder.
    The folder does have setup.exe, setup.ini AND a setup folder in it.
    Still I get 'not a valid installation folder'.

    I tried downloading and installing SQLEXPRADV_x64_ENU.exe from Microsoft's site.
    I get 'known incompatibility issues' as well as 'restart computer - FAILED'.

    I've been developing with Microsoft software since 1994; don't know why I'd be surprised at this.
    I"ve been using Sql Server since '97.

    Is there *any* way to install Sql Server 2008 Express for Visual Studio 2010 Ultimate on Windows 7 64 bit?
    I mean where I can actually end up with a DATABASE!?????????????

    EDIT:

    Well, I've gotten SQLEXPRESS  & SQLEXPRESS2008 installed (or so my services say).
    I've installed SQL Server Express R2 Management Studio successfully.

    STILL - NO DATABASE!!!
    I keep thinking that I need to install an 'instance' of it (could be wrong).
    When I try that it wants me to tell it where the 'installation media' is.
    No matter what I  point it at it says 'not a valid installation folder'.

    EDIT:

    I've verified now that I have THREE instances of Sql Server Express installed and running:
    SQLEXPRESS                        I believe this was installed by VS 2010
    SQLSVREX2008                    this is sp 3
    SQLEX2008R2                      this one is R2

    I have the SQL Express R2 Management Studio installed as well as Visual Studio 2010 Ultimate which has tools to connect to the database.

    I've configured all 3 instances to use my Windows account and password.
    I've also configured them all to fully enable "FILESTREAM".

    I've rebooted 6 times after various installations.

    Neither the Management Studio nor Visual Studio can connect to any of the databases.




    • Edited by Sizzelicks Saturday, January 21, 2012 6:35 AM
    Saturday, January 21, 2012 3:53 AM

Answers

  • My problem was that I couldn't connect to any of the instances from the Sql Server Management Studio or Visual Studio 2010.

    I did find THE SOLUTION:

    In the Sql Server Configuration Manager I made sure that all the protocols (really just needed named pipes) were enabled.
    That still didn't fix it when I typed in the instance name as shown.
    In the SQL Server Configuration Manager 'SQL Server Network Configuration' I clicked 'protocols for SQLEX2008R2' and right clicked then hit properties for 'named pipes'.
    I then copied the entire string for the 'pipe name'.

    I pasted that into the 'Server Name' in both the Sql Server Management Studio and in the Visual Studio 2010 Transact Sql Editor.

    That finally gave me a connection to the R2 instance and now I can create schemas, tables, run queries and whatever I need.

    -----------------

    The functionality was all there.
    VS 2010 did install SQLEXPRESS successfully.
    I'm guessing that if I had known that *secret* about knowing to enable named pipes and to use the entire 'pipe name' string I could have easily connected without any of this trouble.

    I really think that SQL Server Management Studio & VS 2010 Database Connectivitity should have FOUND the database instances when I tried to 'Browse' for them. They were there and they were running. The database connection functionality found NOTHING.
    If the 'default' protocol was 'named pipes' then VS 2010 should have installed SQLEXPRESS with named pipes ENABLED.

    Just to find out what would happen I tried using 127.0.0.1 (localhost) and also localhost to see if it would connect.
    In the Manager's Connection properties I changed the protocol to TCP/IP.
    I made sure TCP/IP was enabled in the SQL Server Configuration Manager's properities for the instance.
    It did not connect.

    Having changed the Sql Server Management Studio's connection property back to 'default' (obviously named pipes) and set it to use the string for 'named pipe':
    I unchecked 'Enable FILESTREAM . . . ' and again used the entire string for 'pipe name'.
    It connected to the R2 database server with no problem.
    That is, enabling the FILESTREAM did nothing to help solve the problem.

    As long as I've known Microsoft I have consistently been disappointed with the documentation.
    Around 2003 it was starting to look better. I'd have to say they've reverted back to 'run around' documentation.

    I just wasted an entire day trying to learn a *secret* that could have been implemented in less than 1 minute.

    Thanks for your quick reply:o)










    • Marked as answer by Sizzelicks Saturday, January 21, 2012 7:24 AM
    • Edited by Sizzelicks Saturday, January 21, 2012 7:54 AM
    Saturday, January 21, 2012 7:21 AM

All replies

  • Hi,

    I belive this walkthrough will help: http://msdn.microsoft.com/en-us/library/ms233763.aspx

    When you install SQL Server you have only system databases, your custm database must be create by yourself using the CREATE DATABASE command or using the gui as mentioned above.

    I hope it helps.

    J.


    There are 10 type of people. Those who understand binary and those who do not.
    My Blog
    Saturday, January 21, 2012 7:05 AM
  • My problem was that I couldn't connect to any of the instances from the Sql Server Management Studio or Visual Studio 2010.

    I did find THE SOLUTION:

    In the Sql Server Configuration Manager I made sure that all the protocols (really just needed named pipes) were enabled.
    That still didn't fix it when I typed in the instance name as shown.
    In the SQL Server Configuration Manager 'SQL Server Network Configuration' I clicked 'protocols for SQLEX2008R2' and right clicked then hit properties for 'named pipes'.
    I then copied the entire string for the 'pipe name'.

    I pasted that into the 'Server Name' in both the Sql Server Management Studio and in the Visual Studio 2010 Transact Sql Editor.

    That finally gave me a connection to the R2 instance and now I can create schemas, tables, run queries and whatever I need.

    -----------------

    The functionality was all there.
    VS 2010 did install SQLEXPRESS successfully.
    I'm guessing that if I had known that *secret* about knowing to enable named pipes and to use the entire 'pipe name' string I could have easily connected without any of this trouble.

    I really think that SQL Server Management Studio & VS 2010 Database Connectivitity should have FOUND the database instances when I tried to 'Browse' for them. They were there and they were running. The database connection functionality found NOTHING.
    If the 'default' protocol was 'named pipes' then VS 2010 should have installed SQLEXPRESS with named pipes ENABLED.

    Just to find out what would happen I tried using 127.0.0.1 (localhost) and also localhost to see if it would connect.
    In the Manager's Connection properties I changed the protocol to TCP/IP.
    I made sure TCP/IP was enabled in the SQL Server Configuration Manager's properities for the instance.
    It did not connect.

    Having changed the Sql Server Management Studio's connection property back to 'default' (obviously named pipes) and set it to use the string for 'named pipe':
    I unchecked 'Enable FILESTREAM . . . ' and again used the entire string for 'pipe name'.
    It connected to the R2 database server with no problem.
    That is, enabling the FILESTREAM did nothing to help solve the problem.

    As long as I've known Microsoft I have consistently been disappointed with the documentation.
    Around 2003 it was starting to look better. I'd have to say they've reverted back to 'run around' documentation.

    I just wasted an entire day trying to learn a *secret* that could have been implemented in less than 1 minute.

    Thanks for your quick reply:o)










    • Marked as answer by Sizzelicks Saturday, January 21, 2012 7:24 AM
    • Edited by Sizzelicks Saturday, January 21, 2012 7:54 AM
    Saturday, January 21, 2012 7:21 AM