none
Unable to start virtual machine in VS 15

    Question

  • Hi:

    Trying to work through MS's Hololen's Origami Project using Unity and VS 15. When I try to build the program in VS, the OS tries to start but I get the error "The emulator is unable to verify that the virtual machine is running.  ... Something happened while starting the a virtual machine: 'Hololens Emulator 10.0.14393.0xxxxx' failed to start.

    Hyper-v is enable.

    Any ideas?

    Thanks.

    • Moved by BrianEhMVP Monday, March 13, 2017 4:04 PM
    Friday, March 10, 2017 10:15 PM

All replies

  • Hi friend,

    Please try the steps below:

    1) Start the app deployment process in VS 2015 by selecting an emulator and then pressing F5

    2) Wait till the emulator starts and shows "OS is starting"

    3) Then, go to the task manager, go to the process of VS 2015 (devenv.exe) and kill it

    Result: The emulator image is being built and the app deployment process cannot fail as VS is not running anymore.

    As soon as the emulator is fully built and you can see Windows Mobile 10 in action, close the emulator and start the app deployment process through VS 2015 again.

    Feel free to let me know if it works.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 14, 2017 10:18 AM
  • Hi Fletch:

    Thanks for offering a solution ... unfortunately I'm getting the same error that "The emulator is unable to verify that the virtual machine is running: " ....

    Cheers,

    Gordon

    Tuesday, March 14, 2017 3:18 PM
  • Hi Gordon,

    I'm just thinking if this could be related to Hyper-v. What if you turn it off? (I'm not professional on it, just a suggestion).

    As answer to this thread mentioned the Hyper-v and VS Emulator may have a conflict, you could refer to Elvis's answer:

    http://stackoverflow.com/questions/39223830/the-emulator-is-unable-to-verify-that-the-virtual-machine-is-running

    I hope it helps.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 15, 2017 6:58 AM
  • No luck with removing Hyper-v ... Never even started.

    Thanks for the suggestion.

    Gordon

    Wednesday, March 15, 2017 5:10 PM
  •  

    Hi Gordon,

    We could not start a emulator in VM. Please make sure that you are not using VM.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 16, 2017 8:33 AM
    Moderator
  • Hi Oscar:

    I do not have VM Ware installed. I turned on Hyper-V and installed Hololens and am running it in VS 15.

    Thanks,

    Gorodn

    Thursday, March 16, 2017 3:29 PM
  • Hi AIM_VR,

    >>Trying to work through MS's Hololen's Origami Project using Unity and VS 15.

    Would you please share us a simple steps about how we could create a simple similar project in our side?

    Whether all projects have the same issue or just the specific one?

    Would you please share us the detailed windows Environment information?

    >>"The emulator is unable to verify that the virtual machine is running.  ... Something happened while starting the a virtual machine: 'Hololens Emulator 10.0.14393.0xxxxx' failed to start.

    I met this issue before which was related to the Visual Studio Emulator for Android or UWP apps before.

    Do you enabled the developer mode?

    Or some troubleshooting steps for Android Emulator, not very sure that whether it is similar to yours, but you could refer to it here:

    https://msdn.microsoft.com/en-us/library/mt228282.aspx

    Thanks,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 20, 2017 9:32 AM
    Moderator
  • Hi Jack:

    I was following the MS Holograms 101E demo code which creates the OrigamiCollection app:

    https://developer.microsoft.com/en-us/windows/holographic/holograms_101e

    I ran into trouble after opening Origami in VS and tried to "Start Without debugging" per the demo's instructions at the end of chapter one. This is the only Hololens project I have been working on.

    I do have Developer Mode enable in Windows.

    I am running Window 10 Pro (64 bit) with 32 GB RAM, i7-4770 CPU (3.4GHZ) and have VS 15 Update 3 (and Unity 5.5.2f).

    Thanks,

    Gordon

    Monday, March 20, 2017 3:37 PM
  • Hi Gordon,

    Just found someone had same issue, and it could be resolved by going into Hyper V manager -> Hyper-V settings. Select the Physical GPUs and Uncheck the box "Use this GPU with RemoteFX".

    Reference thread(reply of user6501589):

    http://stackoverflow.com/questions/31946072/visual-studio-2015-emulator-is-unable-to-verify-that-the-virtual-machine-is-run

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, March 26, 2017 1:28 PM
  • Thanks Fletch. Just tried unchecking the "Use this GPU with RemoteFX" with no luck. Still fails in loading the OS.
    Friday, March 31, 2017 9:41 PM
  • Hi friend,

    One of colleagues had this same issue before, he solved it by repairing his Visual Studio once. 

    I'm not pretty sure it could work for you, but it's an option.

    Best regards,

    Fletch


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Tuesday, April 04, 2017 9:42 AM