locked
Upload Avatar Bug and solved? RRS feed

  • Question

  • User380413204 posted

    Hi,

    Can somebody tell me if they like me are having trouble uploading Avatars?

    Never bothered with this part of Membership.

    Looked through various posts, Buglist among others.

    Some posts concerning the same sort of problem, but don't think I found it being reported as a clear Bug, nor did I find a solution for it.

    It also could be just me of course :-))

    In other words, how is it with uploading Avatars?

    Lex

    Thursday, May 4, 2006 1:45 PM

All replies

  • User654902800 posted
    One issue is where the user was created via the web site config tool instead of via the club site membership signup form. Those users won't have a profile in the club site to upload an avatar to (saving user info like Phone etc won't work either). Other than that I haven't noticed any issues with avatars.
    Thursday, May 4, 2006 3:17 PM
  • User380413204 posted

    Ok,

    I'll explain a bit more about the problem I encounter, its been described before I think.

    When I upload an avatar and check the table I see Binary info (other records with no Avatar contain Null value) So something seems to get uploaded.

    But in the memberlist I see an empty placeholder.

    Lex

     

    Thursday, May 4, 2006 3:27 PM
  • User654902800 posted

    When you upload the avatar do you see the image after you upload it, and then it's not on the list of members page? If that's the case then I'd suspect aggressive browser caching of that page.

    Or you don't see it at all on the upload page? I looked though the code - it determines whether you have an avatar by checking the length of the stuff in the avatar field in the table, so if you have something in there at all, it should at least try to get it. You could, I suppose, have binary data with a length of 0 in there.

    To check that you could right click on the table -> new query-> then just type in

    select datalength(avatar) as avatarsize from memberinfo where firstname = 'yourfirstname'

    and then execute that query and see if it returns 0 or some reasonable number. If it returns 0 then I would guess that whatever file type you're uploading is somehow not being converted to an image by the ImageUtils.MakeThumb() method on line 61 of member_details.aspx (you could set a breakpoint there or something to test that).

    Hope this helps!

    Thursday, May 4, 2006 4:24 PM
  • User380413204 posted

    Hi,

    Did that, one has 1500ish and the other 2300.

    I uploaded an avatar (the same I used) on Angelo's site. That worked fine.

    http://80.126.181.96/web30/member_register.aspx if you would want to see what happens.

    Lex

     

     

    Thursday, May 4, 2006 4:39 PM
  • User380413204 posted

    Problem solved,

    AvatarImageFetch was corrrupted somehow.

    Exchanged it with the original version.

    All seems to work for now.

    Thanks,

    Lex

    Friday, May 5, 2006 12:45 AM