locked
Parse error in WSS site RRS feed

  • Question

  • I am trying to open my central administration and all WSS sites but getting the following error. Any ideas are highly appreciated. i have WSS 3.0 installed on my machine.

    Parser Error

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Data at the root level is invalid. Line 1, position 1.

    Source Error:

    Line 1:  <browsers>
    Line 2:      <browser id="Safari2" parentID="Safari1Plus">
    Line 3:          <controlAdapters>

    Source File: /App_Browsers/compat.browser    Line: 1


    Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

    Tuesday, November 11, 2008 10:22 AM

Answers

  •  For your config file you have to change customErrors mode=Off to see de detail of the error. 

    For the safari problem. I don´t know why sharepoint create a file that broken the site you have to just delete the content of the next root if is a default port 80, like this example: 

    C:\inetpub\wwwroot\wss\VirtualDirectories\80\App_Browsers

    All content of this folder you have to delete.  And you will solve your problem.. is like a bad specification of browsers compatibility.

    Best regards,


    Manolo Herrear
    • Proposed as answer by S.Navid.R Tuesday, February 3, 2009 8:18 AM
    • Marked as answer by Mike Walsh FIN Thursday, March 19, 2009 9:34 AM
    • Marked as answer by Mike Walsh FIN Thursday, March 19, 2009 9:35 AM
    Tuesday, December 16, 2008 5:35 PM

All replies

  • Hello,
    Safari browser on Windows is not supported on Sharepoint. Only MAC version is supported. Some pages may work others will not.
    Please review the link below.
    http://blogs.msdn.com/sharepoint/archive/2006/07/19/671735.aspx


    Regards
    Ivan Bondy - MCPD, MCDBA, MCSA, MCTS - Sharepoint consultant
    Tuesday, November 11, 2008 3:56 PM
  • Hi Ivan,
    Actually there is some problem with my central admin also. I am getting following error.
    even the sites hosted are also not working and giving same error mentioned below. i am using IE 6.0 browser.
    Runtime Error

    Server Error in '/' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>
    is there any change need to be made in web.config...i cant figure it out.
    please suggest some idea to solve.......

    thanks
    Amreesh
    Wednesday, November 12, 2008 8:21 AM
  •  For your config file you have to change customErrors mode=Off to see de detail of the error. 

    For the safari problem. I don´t know why sharepoint create a file that broken the site you have to just delete the content of the next root if is a default port 80, like this example: 

    C:\inetpub\wwwroot\wss\VirtualDirectories\80\App_Browsers

    All content of this folder you have to delete.  And you will solve your problem.. is like a bad specification of browsers compatibility.

    Best regards,


    Manolo Herrear
    • Proposed as answer by S.Navid.R Tuesday, February 3, 2009 8:18 AM
    • Marked as answer by Mike Walsh FIN Thursday, March 19, 2009 9:34 AM
    • Marked as answer by Mike Walsh FIN Thursday, March 19, 2009 9:35 AM
    Tuesday, December 16, 2008 5:35 PM
  • Same problem, a solution :
    when you modify a file with MS Sharepoint Designer, It creates a folder with name _vti_cnf in App_Browsers that another compat.browser is in it.  So after deleting this folder our site started to work fine again. It seems that the best application to open these files i Visual Studio or Virual Web Designer not MS Sharepoint Designer.

    instead : I think for viewing error details you should also change "CallStack" to "true"...


    S.N.R
    http://sharepoint4u.wordpress.com
    S.Navid.R
    • Proposed as answer by S.Navid.R Tuesday, February 3, 2009 8:18 AM
    • Unproposed as answer by Mike Walsh FIN Thursday, March 19, 2009 9:33 AM
    Saturday, January 31, 2009 9:10 AM
  • Manolo,

    why did you propose Amreesh's second post as an Answer ?

    He was giving more information for his problem. It was NOT an answer to his problem.

     

    By all means propose Answers but not questions or further information posts !



    (S.N.R.: don't propose *your own* posts!) 


    WSS FAQ sites: WSS 2.0: http://wssv2faq.mindsharp.com WSS 3.0 and MOSS 2007: http://wssv3faq.mindsharp.com
    Total list of WSS 3.0 and MOSS 2007 Books (including foreign language titles) http://wss.asaris.de/sites/walsh/Lists/WSSv3 FAQ/V Books.aspx
    Saturday, January 31, 2009 11:27 AM
  • Hi All,
    I got the answer. Actually the answer is the combination of both Manolo and R. Navid's Replies. Thanks for the replies. Sorry for the late response to these replies.

    Regards
    Amreesh
    Tuesday, March 17, 2009 5:42 AM
  • S.Navid.R solution works. thanks.
    swfla
    Sunday, June 28, 2009 6:54 PM