none
Emails from SharePoint 2016 workflows (SP 2010 platform workflows) not working

    Question

  • Hello,

    I have created SharePoint designer workflows (Workflow Platform Type - SharePoint 2010) in  SharePoint 2016.

    The workflow runs fine, except that the emails sent in the workflow fail with the following message:

     Mail Subject: Email from workflow - With email address. Error: SmtpException while sending email: System.Net.Mail.SmtpException: Mailbox unavailable. The server response was: 5.7.1 Client does not have permissions to send as this sender    
     at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)    
     at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, MailAddress from, Boolean allowUnicode)    
     at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, Boolean allowUnicode, SmtpFailedRecipientException& exception)    
     at System.Net.Mail.SmtpClient.Send(MailMessage message)    
     at Microsoft.SharePoint.Email.SPSmtpClient.SendOnce(MailMessage msg, Boolean useAlternateServer)    
     at Microsoft.SharePoint.Email.SPSmtpClient.Send(MailMessage msg)

    All the other emails such as OOB Alert emails and emails that are sent when someone is given access are working fine.

    Also, SMTP team says they don't see any error in their logs.

    Few points:

    1. We don't have the workflow manager installed in the farm.

    2. The issue is consistent in dev, staging and production servers

    Any help/pointers are hugely appreciated.

    Many thanks
    Santhosh




    • Edited by sankumarr Wednesday, April 5, 2017 3:01 PM
    Wednesday, April 5, 2017 2:56 PM

All replies

  • Can you send mail from the SharePoint server?  i.e., Powershell send-mailmessage cmdlet?  (Send-MailMessage)

    This sounds like a relay issue, not SharePoint.

     The server response was: 5.7.1 Client does not have permissions to send as this sender    

    MCITP-EA | "Never test how deep the water is with both feet"



    • Edited by ThatGuyRyan Wednesday, April 5, 2017 3:09 PM
    Wednesday, April 5, 2017 2:59 PM
  • Many thanks for your quick reply.

    From Powershell:
    When I send the email with an from address, such as "noreply@mycompany.com", it errors out with the same error message as earlier (The server response was: 5.7.1 Client does not have permissions to send as this sender)

    When I send the email from address as my email address it sends fine without any errors.

    What will the user as which SharePoint designer workflows (SP 2010 platform type) be sent? Also, which process would the workflows be running under?

    Thanks in advance

    Thursday, April 6, 2017 10:19 AM
  • Yes, then it's not a SharePoint issue, it's an issue where the IP of the server sending the email doesn't have access to relay off your SMTP server.  The email header will be whatever is defined in outgoing email settings in CA.  


    MCITP-EA | "Never test how deep the water is with both feet"

    Thursday, April 6, 2017 12:43 PM
  • Thanks again for the reply. We have traced the issue to be from the SMTP Server.

    Although the SMTP team claims that SharePoint designer workflow email is trying to Authenticate itself.

    And since its authenticating, it goes to Exchange Server rather than the SMTP relay and thus could not send the emails with a different from address than the user themselves.

    Is there is a setting somewhere (in SP Designer, Central Admin or elsewhere) where we can mention not to authenticate the emails?

    I did find the setting in IIS of WFE and its already marked as Not required.

    IIS SMTP Setting

    Any other suggestions / advice please?



    • Edited by sankumarr Friday, April 7, 2017 3:43 PM
    Friday, April 7, 2017 3:40 PM
  • What server is configured for outgoing email in CA?

    Is IIS SMTP running on a server?  If it is, you could setup CA to point to it and then smart host out to your SMTP relay server.  

    In either case, this really looks like an issue with SMTP relay.  SharePoint is just sending out an email, there is no auth which is why an open relay is required.  You can lock this down if you're using IIS SMTP to a specific IP or subnet for security.  

    Since you're unable to send an email from powershell (which bypasses SharePoint completely) you need to look at your relay settings on either your spam device OR exchange, whichever is set as your SMTP server.

    MCITP-EA | "Never test how deep the water is with both feet"

    Friday, April 7, 2017 5:32 PM