locked
The specified provider is not supported. Please choose different provider in connection manager. RRS feed

  • Question

  • Hi,

    Do you know any root cause for the occurrence of the below error when we are trying to edit an already existing Oracle connection manager?

    Error : "The specified provider is not supported.  Please choose different provider in connection manager.

    We have checked the server and we do have the required oracle files installed. Also, the package never showed this error before.

    Any help much appreciated!

    Thanks!


    harshac

    Tuesday, February 6, 2018 8:16 PM

Answers

  • Hi Harshac,

    Looks it still is unable to find the proper driver. So it might had been installed under not all users or something.


    Arthur

    MyBlog


    Twitter

    • Marked as answer by Harshac Sunday, July 5, 2020 6:33 PM
    Tuesday, February 6, 2018 9:20 PM
  • Hi Harshac,

    So, which provider and version of SSIS are you using?

    If you are using Microsoft OLE DB Provider for Oracle, this feature will be removed in a future version of Windows. Avoid using this feature in new development work, and plan to modify applications that currently use this feature. Instead, use Oracle's OLE DB provider.

    Download: Oracle Provider for OLE DB

    Regards,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Harshac Sunday, July 5, 2020 6:33 PM
    Wednesday, February 7, 2018 2:22 AM

All replies

  • Hi Harshac,

    Looks it still is unable to find the proper driver. So it might had been installed under not all users or something.


    Arthur

    MyBlog


    Twitter

    • Marked as answer by Harshac Sunday, July 5, 2020 6:33 PM
    Tuesday, February 6, 2018 9:20 PM
  • Hi Harshac,

    So, which provider and version of SSIS are you using?

    If you are using Microsoft OLE DB Provider for Oracle, this feature will be removed in a future version of Windows. Avoid using this feature in new development work, and plan to modify applications that currently use this feature. Instead, use Oracle's OLE DB provider.

    Download: Oracle Provider for OLE DB

    Regards,

    Pirlo Zhang


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Marked as answer by Harshac Sunday, July 5, 2020 6:33 PM
    Wednesday, February 7, 2018 2:22 AM