none
The remote server returned an unexpected response : (405) Method Not Allowed. RRS feed

  • Question

  • We are consuming SAP PI services in .net console appliation.

    But we are getting the "The remote server returned an unexpected response : (405) Method Not Allowed." Error message

    Any idea


    ilikemicrosoft

    Tuesday, February 25, 2014 12:33 PM

Answers

  • There could be 1000 different reasons for this error.  You are making an HTTP connection and the connection failed.  A successful connection will return a status of 200 done .  The first question I need to ask is if this application ever worked?  It is probably a credential issue or a proxy certificate is missing.   The user account that the application is running under must also have access to the service that you are connecting to.  Here are some things to try

    1) From cmd.exe try ping the server by both IP address and computer name.  Sometimes one works and the other doesn't

    2) From cmd.exe on both client and server PC try command : Netstat -a.  check the port number to see that status of the port the applicaitton is using.  It is possbile another application is using the port or the port didn't close the last time the application was used.


    jdweng

    Tuesday, February 25, 2014 12:57 PM

All replies

  • There could be 1000 different reasons for this error.  You are making an HTTP connection and the connection failed.  A successful connection will return a status of 200 done .  The first question I need to ask is if this application ever worked?  It is probably a credential issue or a proxy certificate is missing.   The user account that the application is running under must also have access to the service that you are connecting to.  Here are some things to try

    1) From cmd.exe try ping the server by both IP address and computer name.  Sometimes one works and the other doesn't

    2) From cmd.exe on both client and server PC try command : Netstat -a.  check the port number to see that status of the port the applicaitton is using.  It is possbile another application is using the port or the port didn't close the last time the application was used.


    jdweng

    Tuesday, February 25, 2014 12:57 PM
  • When I run process on machine with visual studio it is run when I run on server it is not. I can access resource on server over IE but not with WebReques
    Friday, July 25, 2014 5:00 PM