locked
2010 Access Web Report missing scrollbar in SharePoint RRS feed

  • Question

  • So I've research this issue here and I've not been about to find a post with a problem exactly like mine. I have a Access Web DB form that has text and combo boxes. At the press of a button, a report opens and is filtered based on the information (if any) in the form. I use an event procedure to a call a series of If -> then, elseif->then,  else -> conditions to accomplish this using the OpenReport action and criteria in the where condition. This seems to work fine in the database but when I use it via SharePoint, I can only see the first part of each page of the report as there is no vertical scrollbar. When I export to a PDF, I see the correct report. After researching a few other posts, I added the RefreshRecord action after the OpenReport action but that did not solve the problem. This is the first time that Im dealing with the system of SharePoint and Web DBs. Can someone please help point me in the right direction.

    Thanks

    Lambo

    Wednesday, March 8, 2017 9:58 PM

Answers

  • Hello.

    I was able to find a solution using temp variables and the BrowseTo marco. Thanks for your help with this.

    • Marked as answer by Lambo Pamps Wednesday, March 15, 2017 7:16 PM
    Wednesday, March 15, 2017 7:16 PM

All replies

  • Hi Lambo Pamps,

    looks like an interface related issue.

    can you post the picture of that report so that we can try to see it.

    it is more helpful to us to understand the issue.

    if it the solution is available then we can try to provide you.

    otherwise we will try to submit the feedback to access user voice regarding this issue to correct it.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, March 9, 2017 4:49 AM
  • Thanks for your response. Here are images.

    Exhibit A- When I open with the OpenReport action and a condition using an event procedure – no scroll

    (I am unable to attach pictures. I receive a message stating that I will be able to do so after an account verification)

    Exhibit – B When I export the report above to PDF using the actions-> export option, I see the entire report with a scroll

    Exhibit C - When I view the unfiltered report from the objects in the SharePoint settings – I have a vertical scroll

    Maybe this is a design issue?! I'm not sure. I’ve also noticed that if I put the report in a form and call the OpenForm action, a scroll appears, however, the report does not open with correct conditions applied. Is there a way to get the scroll to appears for Exhibit – A? Any other way? I need to be able to see the scroll on the screen and not export to PDF for every search just to see the entire report.

    Thursday, March 9, 2017 6:27 PM
  • Hi Lambo Pamps,

    you can try to upload the images on free image hosting sites then try to share the link of images as text.

    then we will able to access that image.

    so we will try to look the images and try to get the idea about your issue.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 13, 2017 6:23 AM
  • Ok. Thanks for sticking with me here.

    Here is a link with the problem, questions and images.

    http://sharepoint.stackexchange.com/questions/210419/2010-access-web-report-missing-scrollbar-in-sharepoint

    Monday, March 13, 2017 5:43 PM
  • Hi Lambo Pamps,

    after checking in Access Web app , I find that we don't have control for that scrollbar or don't have any control so that we can set the number of records to display per page.

    so it's like a design issue, and because of that you are not able to see the all the data with in that page.

    please try to submit your feedback to access user voice.

    Access User Voice

    Access developers will try to test it and hope they will correct this issue soon.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, March 14, 2017 9:29 AM
  • Hello.

    I was able to find a solution using temp variables and the BrowseTo marco. Thanks for your help with this.

    • Marked as answer by Lambo Pamps Wednesday, March 15, 2017 7:16 PM
    Wednesday, March 15, 2017 7:16 PM