locked
SharePoint 2013 Workflow Error +Suspend +terminate+ goes in Activity In progress state+ HTTP InternalServerError + An unhandled exception occurred RRS feed

  • Question

  • Hi,

    We have a SharePoint 2013 List level multistate parallel block approver workflow. Suddenly it's started suspending or terminating  may be while assigning task to users. But some workflow complete successfully.

     

    When I trigger workflow parallel block logic should work and need to assign task to respective users. But sometimes its assign task to all users in parallel block and some not and goes into activity in progress state. After particular time duration its shows error messages:

    [Note]: Same workflow when I I retry It sometimes it work or sometimes not. I checked workflow logic its fine and I used App step in that workflow.

    We checked below few steps to resolve but still no luck:

    1. We checked  Workflow logic its fine becoz it was working before 2 month ago.
    2. No user migration done still date.
    3. Checked user profile service and synchronization service  and all are up & running.
    4. Checked faulty user/ those user not assign task  in user information list but all email and contact name properties are mentioned properly.
    5. We tried after doing deactivating and activating Workflows can use app permissions feature.
    6. Tried after republishing workflow but same issue.
    7. Granted full app permission through site settings but no luck

     

    Below are few Workflow Error:

    Error Message1:

    Resume this workflow

    RequestorId: <guid>. Details: An unhandled exception occurred during the execution of the workflow instance. Exception details: System.ApplicationException: HTTP 500 {"SPRequestGuid":["<guid>"],"request-id":["<guid>"],"X-FRAME-OPTIONS":["SAMEORIGIN"],"SPRequestDuration":["185"],"SPIisLatency":["0"],"MicrosoftSharePointTeamServices":["15.0.0.4481"],"X-Content-Type-Options":["nosniff"],"X-MS-InvokeApp":["1; RequireReadOnly"],"Date":["Wed, 09 Mar 2016 09:13:50 GMT"],"Server":["Microsoft-IIS\/8.0"],"X-Powered-By":["ASP.NET"]} at Microsoft.Activities.Hosting.Runtime.Subroutine.SubroutineChild.Execute(CodeActivityContext context) at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager) at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

     

     

    Error message 2:

    Activity in progress

     Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP InternalServerError to https://<SiteName>/_vti_bin/client.svc/web/lists/getbyid(guid'<guid>')/Items(12)?%24select=ID%2CABC Correlation Id: <guid> Instance Id: <guid> Retry now

     

    Error Message 3:

    Activity in progress

     Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP InternalServerError to https://<sitename>/_vti_bin/client.svc/Web/SiteUserInfoList/Items?%24filter=Id+eq+883&%24select=Name Correlation Id: <guid> Instance Id: <guid> Retry now

    Error Message 4:

    Retrying last request. Next attempt scheduled in less than one minute. Details of last request: HTTP InternalServerError to http://<sitename>/_vti_bin/client.svc/sp.utilities.utility.SendEmail

    Your helps will be very appreciated.

    Thanks/ Siddheshwar Kohale

    Thursday, March 10, 2016 8:20 AM

All replies

  • Hi Siddheshwar Kohale,

    According to your description, your workflow suspended with HTTP error.

    1. Please make sure SMTP service has been started:
    http://designerworkflow.blogspot.jp/2014/02/error-requestorid-1ca8de59-3d62-782a.html

    2. Check outgoing email settings for the farm are correct.

    3. Disabled firewall on the Exchange/SMTP server.

    4. Check App management service is running.

    5. Do a full user profile synchronization manually.

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, March 11, 2016 3:13 AM
  • HI Chris,

    As you suggested I performed few steps:

    Actually I noticed that some user those are part of problematic workflow having two accounts ex.DomainAccount1\demouser and DomianAccount2\demouser. In that few users DomainAccount1\domeuser emailID Field are missing. And we are using DomainAccount2\demouser in workflow which is correct. Considering this point I dig into that But This issue occur for those user who have properly mentioned all the user profile properties as well.  For Same user one workflow works properly but other get stuck and throws internal server error. I'm unable to concrete the solution where  the exactly problem is.

    I have mentioned all the error message at the start of my thread. 

    Can you please provide your comment why particular issue occur those are mentioned above.

    Your helps is very appreciated.

    Thanks/Siddheshwar Kohale

    Monday, March 14, 2016 4:32 AM
  • Hi ,

    For the 2,3,4 error, please go to ULS logs to find more information.

    C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\LOGS

    You can try:
    1.Go to central admin, Select Web application URL and click on User Policy --> For all required admins,Farm account users provide permissions as all zones with full control.

    2.Go to UserProfile service(Any SA) and select the Permissions option and all above users give the same permissions.


    Wednesday, March 23, 2016 1:53 AM
  • Thanks,

    I traced ULS Logs files based on correlation ID and I found few exception messages. Please check and comments accordingly.

    Exception 1: Original error: User Profile Application: SynchronizeMIIS encounters an exception: System.NullReferenceException: Object reference not set to an instance of an object.    
     at Microsoft.Office.Server.UserProfiles.UserProfileImportJob.<>c__DisplayClass2.<IsTimerJobRunning>b__1()    
     at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass5.<RunWithElevatedPrivileges>b__3()    
     at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)    
     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)    
     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)    
     at Microsoft.Office.Server.UserProfiles.UserProfileImportJob.IsTimerJobRunning(UserProfileApplicationJob timerJob)    
     at Microsoft.Office.Server.Administration.UserProfileApplication.SynchronizeMIIS()    
     at Microsoft.Office.Server.Administration.ILMProfileSynchronizationJob.Execute() "ID,Product_x0020_Cost Correlation Id: 57b9623f-e99f-b0de-9146-d3998e5216a7 Instance Id: 6fca4f9e-1f64-4321-badc-033803f8deb3" is not valid.    
     at Microsoft.SharePoint.Client.Rest.EdmExpressionParser.Expect(Tokens tokType)    
     at Microsoft.SharePoint.Client.Rest.EdmExpressionParser.ParsePropertyList(Boolean allowWildcard)    
     at Microsoft.SharePoint.Client.Rest.RestRequestProcessor.CreateRestQueryFromQueryStrings()    
     at Microsoft.SharePoint.Client.Rest.RestRequestProcessor.Process()    
     at Microsoft.SharePoint.Client.Rest.RestRequestProcessor.ProcessRequest()    
     at Microsoft.SharePoint.Client.Rest.RestService.ProcessQuery(Stream inputStream, IList`1 pendingDisposableContainer)

    Exception 2:

    User Profile Application: SynchronizeMIIS encounters an exception: System.NullReferenceException: Object reference not set to an instance of an object.    
     at Microsoft.Office.Server.UserProfiles.UserProfileImportJob.<>c__DisplayClass2.<IsTimerJobRunning>b__1()    
     at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass5.<RunWithElevatedPrivileges>b__3()    
     at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)    
     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param)    
     at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode)    
     at Microsoft.Office.Server.UserProfiles.UserProfileImportJob.IsTimerJobRunning(UserProfileApplicationJob timerJob)    
     at Microsoft.Office.Server.Administration.UserProfileApplication.SynchronizeMIIS()    
     at Microsoft.Office.Server.Administration.ILMProfileSynchronizationJob.Execute()

    Exception 3: 

    Original error: Microsoft.SharePoint.Client.InvalidClientQueryException: The expression "ID,product_x0020_Cost Correlation Id: 57b9623f-e99f-b0de-9146-d3998e5216a7 Instance Id: 6fca4f9e-1f64-4321-badc-033803f8deb3" is not valid.    
     at Microsoft.SharePoint.Client.Rest.EdmExpressionParser.Expect(Tokens tokType)    
     at Microsoft.SharePoint.Client.Rest.EdmExpressionParser.ParsePropertyList(Boolean allowWildcard)    
     at Microsoft.SharePoint.Client.Rest.RestRequestProcessor.CreateRestQueryFromQueryStrings()    
     at Microsoft.SharePoint.Client.Rest.RestRequestProcessor.Process()    
     at Microsoft.SharePoint.Client.Rest.RestRequestProcessor.ProcessRequest()

    Your input will be very appreciated.

    Thanks/ Siddheshwar Kohale

    Monday, March 28, 2016 6:14 AM