none
Visual Studio 2015 - WindowsBase version 4.0.0.0 - error - devenv.exe log file included

    Question

  • Ran devenv.exe /log c:\vs-log.log to get out put.

    How can I resolve this? devenv.exe /safemode and devenv.exe /resetsettings do NOT work.

    Here are the offending lines:

      <entry>
        <record>25</record>
        <time>2016/12/26 01:25:20.705</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>SetSite failed for package [Async Query Service Package]</description>
        <guid>{DD7B74B5-C1F9-411A-B22E-5E711592BC6B}</guid>
        <hr>8007000b</hr>
        <errorinfo>Could not load file or assembly 'WindowsBase, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. An attempt was made to load a program with an incorrect format.</errorinfo>
      </entry>
      <entry>
        <record>26</record>
        <time>2016/12/26 01:25:20.707</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>End package load [Async Query Service Package]</description>
        <guid>{DD7B74B5-C1F9-411A-B22E-5E711592BC6B}</guid>
        <hr>8007000b</hr>
        <errorinfo>Could not load file or assembly 'WindowsBase, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. An attempt was made to load a program with an incorrect format.</errorinfo>
      </entry>

    Monday, December 26, 2016 2:36 AM

All replies

  • I found the correct version of the dll in "C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\dg14a1ck.mh1\WindowsBase.dll"

    I attempted to add it to the GAC using gacutil -i and got:

    "Failure adding assembly to the cache:   An attempt was made to load a program with an incorrect format."

    Somehow this dll has become corrupt?

    Monday, December 26, 2016 2:50 AM
  • Hi jc0000,

    When did this issue happen? Did it happen when you started VS or after you did some operations?

    To check if the WindowsBase.dll is corrupt, you could try the following two suggestions.

    You could repair your VS as following steps:

    Open Control Panel -> Programs -> Programs and Features -> choose VS -> Right-click -> Change - > Repair

    Or you could try to install windows update, if your system was crash during installing updates.

    In windows 10 you could install update as following:

    Choose start -> setting -> Update & security

    Best regards,

    Fletcher


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, December 27, 2016 8:42 AM