locked
MDB Lock File RRS feed

  • Question

  • User66879988 posted
    Dear all, When make query or update to the Access 2000, the system will generate a MDB Lock file for integrity. The lock file sometimes cannot be deleted programmatically even I used "objDataReader.Close();" each time for querying the DB. Does anyone give some suggestions on how to make sure that the lock file must be deleted after executing the query or update? Regards, Joe
    Wednesday, April 28, 2004 9:25 AM

All replies

  • User-1122936508 posted
    The lockfile is managed by the Jet OLEDB Provider. OLEDB Resource Pooling means that the lockfile should hang around for a little while (60 seconds), whilst the pool is maintained. When the pool is destroyed (60 seconds after the last request), then the lockfile should disappear. If it doesn't, ensure that that the Creator_Owner account has full permissions to the folder that Access .mdb file is in. Cheers Ken
    Wednesday, April 28, 2004 11:00 AM
  • User-442214108 posted
    make sure you do a connection.close along with Ken's suggestion the aspnet user must have modify permissions for the folder where the database resides.
    Wednesday, April 28, 2004 11:27 AM
  • User1628746328 posted
    I've been experiencing a similar problem. All of my datareaders and connections are closed, however, the lock file is not being deleted. If I try to change permissions for CREATOR OWNER, by clicking on the checkboxes in the Security tab of the Properties window, and click on Apply, the checkboxes are unchecked when I click the Apply button.. Very wierd. Any ideas would be appreciated! THanks. Doug Dexter
    Wednesday, June 23, 2004 6:41 PM
  • User1569398160 posted
    May I ask further questions? I have similar problems. I have checked the older post but still get no clues... Under 'normal development' environment, all work fines. (I mean single access certainly.) I have inserted the "close" and "set to nothing" once the connection is done. And I use reader only for testing. Case 1. to simulate the multi-users environment, I opened the access tables (using MS Access). Then I "F5" the pages, however it indicates that the tables are opened by other users and cannot be accessed. (? why? It is not open exclusively.) Case 2. I return to normal. -> closing the access. Re-start the pages. It works fine. Then I close the page and try to open the access file but it is locked. (? Why? there is no locking file already.) Thus, is it saying that access mdb is not for ASP.net multiuser environment? Even the locking file is destroyed, I could not immediate open the access file by opening it directly -> is it a timeout problem only? If yes, how can I shorten the timeout time? Thanks and regards.
    Friday, June 25, 2004 12:01 PM
  • User1628746328 posted
    I'm getting nowhere fast with this error: [OleDbException (0x80004005): Unspecified error] I've tried: 1). Changing permissions on the directory 2). Changing permissions on the database 3). THIS: http://support.microsoft.com/default.aspx?scid=kb;en-us;825738 4). Disposing all commands. 5). Closing all connections. 6). Destroying all connections, commands and connection string objects. Let me quickly explain how the page works (or is supposed to work). There is a data grid. Within this datagrid, I have several asp controls (a drop down, 2 check boxes, and 2 listboxes). This data grid has paging functionality and update functionality. For a few clicks, the page works. IE: 1). It updates. 2). It pages, et cetera. Then the problem occurs which is this error: [OleDbException (0x80004005): Unspecified error] I can't figure it out. Any help?!? Thanks. Doug
    Friday, June 25, 2004 1:52 PM
  • User-442214108 posted
    I have seen circumstances where there was a hiccup in the database itself that caused this - in those situations, I created a new database, imported all the tables - deleted old/renamed new, etc.....then, everything was well with the world. It hasn't happened too many times....but it HAS happened
    Friday, June 25, 2004 4:37 PM
  • User1628746328 posted
    Creating a new database... Wow, that sounds like a daunting task...Maybe as a last resort. One more thing. When I re-compile the application, the lock file is deleted. ? Any help would be appreciated. Doug D.
    Friday, June 25, 2004 9:01 PM
  • User-1709218876 posted

    Hi I got similar problem in using access .mdb file in asp.net. 1st I had problem of getting error : file is already in use that was fixed by help of some1 by giving permission to creator but after this problem fixed still I get other error sometimes(maybe when more than 1visitor apply in same time) : 'No value is given for one or more parameters'. error occurs in this line : cb.executereader()  <cb is my commandbuilder variable>

    any1 know solution? Do I have to lock the file?

    Tuesday, March 3, 2009 7:46 PM
  • User-1199946673 posted

    You reopened a topic from 2004, and the error you're getting now has nothing to do with the orginal post!!!!

    "No value is given for one or more parameters" usually means that yoú're using a table and/or fieldname in your SQL statement which doesn't exists. So check your SQL statement. If you don't find the problem, please open a new topic and show us your code?

    Tuesday, March 3, 2009 9:23 PM
  • User-821857111 posted

    Hi I got similar problem in using access .mdb file in asp.net.
     

    http://www.mikesdotnetting.com/Article.aspx?ArticleID=69

     

    Wednesday, March 4, 2009 2:53 AM
  • User-1709218876 posted

     hey mike you had showed me this another time. I have not enough time to read this but if you mean I should start a new topic unfortunately I can not find button for starting new topic

    Friday, March 6, 2009 7:35 AM
  • User-1709218876 posted

      No I get this error only when more than 1 visitor request the page. in other times it is always working properly without error thats why I wondered it may has something to do with locking file and posted here. I know this error means fieldname dosnt exist but I get it only when the website is busy

    Friday, March 6, 2009 7:40 AM
  • User-1199946673 posted

    unfortunately I can not find button for starting new topic

    Go to the home page of the forum in which you would like to ask a question, in this case

    http://forums.asp.net/55.aspx

    And ther you'll find a button  Write a New Post

    Friday, March 6, 2009 11:31 AM
  • User-821857111 posted

    I have not enough time to read this
     

    I would urge you to invest 10 minutes in reading the advice at the link.  It will save you days of time in the future.  For example, one of the pieces of advice in the article suggests you copy and paste your error message into Google. You would have instantly found thousands of posts and articles that would have answered your question.  But then I suppose you would be too busy to read any of them.  It's a hard life...

     

    Friday, March 6, 2009 3:04 PM
  • User-1709218876 posted

     lmao

    ok

    but where is new topic starting button that i cant find?

    Friday, March 6, 2009 3:30 PM
  • User-1709218876 posted

     ok ty

    Friday, March 6, 2009 3:32 PM