locked
How to deploy the app on iOS device from visual studio with xamarin RRS feed

  • Question

  • User85043 posted

    I am new to Xamarin and when I switched from Ionic to Xamarin, I was all thrilled about getting myself a native app, and then run it on iOS and Andorid easily, just like how I do it for Ionic. But the truth is that its not really easy, as it may sound.

    The first big trouble is getting connected to a mac, using mac agent. I have to delete mtbs, XMS folder, and killall mono everytime I want to connect mac agent to mac.

    After getting my mac connected to VS2015, now I am struggling with an error "The IBTool task failed unexpectedly", there is another one "Info.plist" file not found. I have tried to provision my device using xCode, created a dummy project on mac. But I cant get pass these errors. After spending couple of days through various forums articles, I am giving up and submitting to this forum. And I am hoping that someone would either point me in right direction or atleast give me link to a blog/article/video that shows how exactly one is suppose to deploy iOS app from PC to real device using mac.

    Error: Error The "IBTool" task failed unexpectedly. (rest of the information in file attached)

    MAC Agent: Starting Agent Designer 4.1.0.530... Agent Designer 4.1.0.530 is running An error occured starting the Designer 4.1.0.530 agent: The operation has timed out.

    The Xamarin Mac Agent could not be fully started. Agents not started: IDB 4.1.0.530, Designer 4.1.0.530. Please check the logs for more details. Connected to the Mac 192.168.100.6 (192.168.100.6) with Limited support.

    Visual Studio Build Log: (see attached file)

    I have tried following: Clean solution, clean project, build project, build solution, rebuild project, rebuild solution. Rebuild dummy project on mac. Restart MAC/PC several times. Deleted mac from agent list. Delete mtbs, XMS folders. Kill mono, restart sharing service. Change permission on .SSH folder and filers on mac. Delete files from MonoTouch folder on PC. Add "UseDNS no" flag in configuration file for SSH

    Just looking for someone to point me in right direction, I am happy to do things on my own.

    Friday, June 24, 2016 10:01 PM

All replies

  • User7270 posted

    I'm having an almost identical problem too. Does anyone have any suggestions?

    Saturday, July 9, 2016 8:34 PM
  • User219321 posted

    I'm having the same problem right now.

    Friday, August 19, 2016 10:27 AM
  • User330951 posted

    go through this link. https://www.youtube.com/watch?v=oUgM5MG0HDQ hope you will get some idea

    Friday, August 11, 2017 11:36 AM