none
Can I install .net 3.5 sp1 without .net 3.5 ? RRS feed

  • Question

  • Hello there,

    I have one query in my mind. Is it possible to install .net 3.5 sp1 if my machine don't have .net3.5 installed on it.

    Also if I have .net 4.0 installed, do I need .net 3.5 to be installed on my machine ? My application is built using .net 3.5.

    Thanks in advance for any kind of feedback.

    Wednesday, April 25, 2012 6:28 AM

Answers

  • No, you cannot install a Service Pack for a product that is not on your system.

    If the program in question requires .NET Framework 3.5, having .NET 4.0 does not help you. You must have the version required by the software.

    However, the cumulative installer for .NET Framework 3.5 SP1 includes .NET 3.5 and all other prerequisites, so a single installer will do the job for you:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before you install! What is your Windows version and Service Pack level?

    If you have Windows 7, .NET 3.5 SP1 is already installed as part of the OS and you will need completely different procedures.

    • Marked as answer by Vjoyism Thursday, April 26, 2012 5:37 AM
    Wednesday, April 25, 2012 1:41 PM

All replies

  • No, you cannot install a Service Pack for a product that is not on your system.

    If the program in question requires .NET Framework 3.5, having .NET 4.0 does not help you. You must have the version required by the software.

    However, the cumulative installer for .NET Framework 3.5 SP1 includes .NET 3.5 and all other prerequisites, so a single installer will do the job for you:

    http://download.microsoft.com/download/2/0/e/20e90413-712f-438c-988e-fdaa79a8ac3d/dotnetfx35.exe

    Before you install! What is your Windows version and Service Pack level?

    If you have Windows 7, .NET 3.5 SP1 is already installed as part of the OS and you will need completely different procedures.

    • Marked as answer by Vjoyism Thursday, April 26, 2012 5:37 AM
    Wednesday, April 25, 2012 1:41 PM
  • .net framework 3.5 sp1 is cummulative package for .net framework 2.0 sp2 , 3.0 sp2 and .net 3.5.

    your application will work fine if you have net 3.5 sp1 on the machine.

    Also windows 7 & server 2008 r2 comes with inbuilt .net framework 3.5 sp1.


    • Edited by Keshav Jain Wednesday, April 25, 2012 1:46 PM
    Wednesday, April 25, 2012 1:46 PM