none
Approval Workflows with Browser-Based InfoPath Forms Not Opening In Browser RRS feed

  • Question

  • Hello,

    I have an InfoPath forms document library with browser-based forms.  Once a user submits a form, I have them utilize the built-in Approval workflow.  The approval workflow emails the approver and provides a link to the document.  When they click the link in the email, it trys to download the InfoPath XML form instead of opening in the browser.

    How do I get it to open the form in the browser when I user clicks the link to it from the email or the approval task in the tasks list?

    Thanks
    Wednesday, November 4, 2009 9:20 PM

Answers

  • That's the problem with using the OOTB workflows. They simply send a link directly to the XML file, but that link isn't what opens the form in the browser.  The browser URL is way longer and much different, so you need to send that instead.  Since you can't modify OOTB workflows, then it's not something you can configure.  If you make your own workflow with SharePoint Designer, then you can dynamically generate the browser URL for the form so that it opens in the browser.  If you want to do that, I can show you quickly how to do it.  If you must stick with the OOTB workflow, then the forms will only open in the browser if the user does not have InfoPath 2007.
    SharePoint Architect || My Blog
    Thursday, November 5, 2009 2:52 AM

All replies

  • That's the problem with using the OOTB workflows. They simply send a link directly to the XML file, but that link isn't what opens the form in the browser.  The browser URL is way longer and much different, so you need to send that instead.  Since you can't modify OOTB workflows, then it's not something you can configure.  If you make your own workflow with SharePoint Designer, then you can dynamically generate the browser URL for the form so that it opens in the browser.  If you want to do that, I can show you quickly how to do it.  If you must stick with the OOTB workflow, then the forms will only open in the browser if the user does not have InfoPath 2007.
    SharePoint Architect || My Blog
    Thursday, November 5, 2009 2:52 AM
  • I am agree with Clayton's reply.. You need to Un-install InfoPath Form application from your system.. This is the only solution for above problem..
    Ashwin B. | My Blog | Twitter | E-Mail
    Thursday, November 5, 2009 6:24 AM
  • Hi chapman85,

     

    Could you please let me know if Clayton’s suggestion is helpful for your issue?

    If you need further assistance, please feel free to let me know.

     

    Have a nice day!

     

    Lambert Qin

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact mtngfb@microsoft.com  


    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, November 10, 2009 4:05 AM
  • Do you have any good tutorials on creating a workflow that operates in a similar fashion to the OOTB approval workflow?
    Friday, November 13, 2009 7:25 PM
  • I am having the same problem and am not using the OOTB workflow. All my workflow is to do at this point is email the manager of the form. Which it does. I am using the [%Current Item:Encoded Absolute URL%] in the hyperlink and it is sending me to open in Infopath and not web services. Ideas? Am I using the wrong lookup?
    Friday, May 28, 2010 8:21 PM
  • Yeah, Encoded Absolute URL is just the direct XML link.  I can show you how to make it open in the browser, but first, please create a new thread.  This one is already answered and is about a different question, so if we go on a tangent, people won't find it in the future.
    SharePoint Architect || Microsoft MVP || My Blog
    Friday, May 28, 2010 8:26 PM
  • Hi,

    Will you please post how to generate the browser URL for the form so that it opens in the browser.

    Wednesday, March 7, 2012 9:37 AM
  • Hi Clayton,

    I have create browser enabled Infopath form and configured SharePoint Designer 2010 Approval workflow.When I click form in library, it's opening up in browser but when I click link in email, it trys to download the InfoPath XML form instead of opening in the browser.

    How do I get it to open the form in the browser when I click the link in email or the approval task in the tasks list?

    Any help would be appreciated.

    Thank you.

    AA

    • Edited by OK29 Wednesday, September 23, 2015 4:45 AM AA
    Friday, April 6, 2012 7:52 PM
  • Hi There Clayton,

    I have the exact same problem and the solution you showed to this user is what I think I need to fix my issue. Please will you let me know how you managed to resolve this, or where I can find the Solution?

    Thanks in advance!

    Kind Regards,

    Riaan

    Tuesday, April 1, 2014 8:32 AM
  • Hi Riaan,

    Where you able to fix the issue ? If yes, please mention the solution.

    Regards,

    Vineeth

    Monday, September 15, 2014 10:09 AM