locked
Windows Mobile Deveice Center cannot connect RRS feed

  • Question

  • I have Windows 7 Ultimate x64 with a Virtual Windows 7 x86.
    In the virtual W7 I installed VS2008 for winmo development (added sdks etc.). 
    Now the Windows Mobile Device Center cannot connect to the device unless I disable integration features.
    Is this the expected behaviour ?
    Any workaround (other than disbale integration features) ?
    (Please don't ask me how the USB attach can work witj integration features disabled, I have no clue)

    Monday, October 4, 2010 9:02 PM

Answers

  • I think you need to install WMDC on the x64 side (with the virtual machine closed), pay attention to use the correct x64 bits.
    Let windows 7 x64 to correctly see the device(you can browse the device from file explore).
    Then run the virtualPC machine WITH the integration features turned ON.
    When the virtual PC OS is running you can see a menu "USB", click on it and select from the list of USB attached device, the WM6.5 device connection to share via USB with the virtual machine.
    At that time the WMDC in the virtual PC will come to see the device correctly.
    In brief: The device need to be recognized by the "main" OS (the x64 one), in order to be share it with the hosted machine (virtualPC one)
    Let me know if it work for you (it work for me)
    Marco
    • Edited by Marco Dal PinoMVP Friday, October 8, 2010 4:02 PM miss some information
    • Marked as answer by warrentang Monday, October 11, 2010 1:33 AM
    Friday, October 8, 2010 2:04 PM

All replies

  • Hi Eager2008,

     

    Better to ask your question in Windows Phone 7 for your solution.

    Windows Phone 7

    Hope it helps.


    If you find my post is helpful for you then mark as a answer.
    Tuesday, October 5, 2010 10:55 AM
  • Perhaps, but I am not talking about WP7.

    My "problem" is with virtual Windows 7 Ultimate x86 to be connected to a Windows Mobile 6.5 device.

    Tuesday, October 5, 2010 2:26 PM
  • What do you mean by "integration features"? Why do you have to use a virtual machine?
    Please mark the post that helps you, and unmark that does not. This benefits our community.
    Thursday, October 7, 2010 7:27 AM
  • Please start a WVPC (guest = Windows 7) in windows mode (not full screen) and select the Tools menu item "Enable (or disable) Integration Features" (just below the WVPC title bar)and you see what I mean.

    Reason for running WVPC is due to some beta installations etc. which I feel is better to run in a virtual PC.

     

    Thursday, October 7, 2010 8:36 PM
  • I think you need to install WMDC on the x64 side (with the virtual machine closed), pay attention to use the correct x64 bits.
    Let windows 7 x64 to correctly see the device(you can browse the device from file explore).
    Then run the virtualPC machine WITH the integration features turned ON.
    When the virtual PC OS is running you can see a menu "USB", click on it and select from the list of USB attached device, the WM6.5 device connection to share via USB with the virtual machine.
    At that time the WMDC in the virtual PC will come to see the device correctly.
    In brief: The device need to be recognized by the "main" OS (the x64 one), in order to be share it with the hosted machine (virtualPC one)
    Let me know if it work for you (it work for me)
    Marco
    • Edited by Marco Dal PinoMVP Friday, October 8, 2010 4:02 PM miss some information
    • Marked as answer by warrentang Monday, October 11, 2010 1:33 AM
    Friday, October 8, 2010 2:04 PM