locked
not able to connect to internet in emulator using windows mobile device center RRS feed

  • Question

  • Hi , when i cradle emulator for internet, my emulator acts as a portable mass storage. I mean that i was able to view the files in the smartphone, but when tried to connect to internet i am getting alert "The page cannot be displayed or download stopped ..... connection lost. Try again". And the Windows Mobile Device center home page(where the 'setup device' and 'connect without setting device' options are available) came only when i installed it, after that whenever i cradle the windows mobile device center home page doesnt turn out. Could anyone help me to resolve the internet connectivity issue?

    i use windows vista, windows mobile 5 sdk, visual studio, windows mobile device center..

    - rahul
    Thursday, April 23, 2009 8:37 PM

Answers

  • Open WMDC and click "Mobile Device Settings" -> "Connection Settings" -> Check "Allow connections to one of the following" and select DMA on the combo box. On VS 2008, start the Device Emulator Manager, select your emulator, right-click it and cradle it. You should now be able to connect the emulator to the internet (WMDC will also recognize the emulator as a cradled device).

    João Paulo Figueira (Device Application Development MVP)
    • Proposed as answer by warrentang Thursday, April 30, 2009 4:12 AM
    • Marked as answer by warrentang Thursday, April 30, 2009 4:12 AM
    Friday, April 24, 2009 10:28 AM
  • I wasnt able to choose "Mobile Device Settings" because, when i tried opening WMDC, directly the Connection Settings dialog pops up. And selecting DMA doesnt resolved my issue.

    But i have got the answer from other threads like, we need to establish a partnership for the first time when we connect our emulator, only then the internet connection is available in the emulator. And also this partnership should need to be compulsarily done at the first time of the sync of the emulator. Because what happened to me is, the first time i didnt selected "Setup Partnership" rather i chose "connect without device setup" and afterwards whenever i opened WMDC, only the connection settings dialog pops up. The wmdc home/startup page containing the "Setup Partnership" never came. So I just reinstalled the WMDC and did setup partnership and now everything works fine... :)


    - rahul
    Friday, May 1, 2009 7:53 PM

All replies

  • Open WMDC and click "Mobile Device Settings" -> "Connection Settings" -> Check "Allow connections to one of the following" and select DMA on the combo box. On VS 2008, start the Device Emulator Manager, select your emulator, right-click it and cradle it. You should now be able to connect the emulator to the internet (WMDC will also recognize the emulator as a cradled device).

    João Paulo Figueira (Device Application Development MVP)
    • Proposed as answer by warrentang Thursday, April 30, 2009 4:12 AM
    • Marked as answer by warrentang Thursday, April 30, 2009 4:12 AM
    Friday, April 24, 2009 10:28 AM
  • I wasnt able to choose "Mobile Device Settings" because, when i tried opening WMDC, directly the Connection Settings dialog pops up. And selecting DMA doesnt resolved my issue.

    But i have got the answer from other threads like, we need to establish a partnership for the first time when we connect our emulator, only then the internet connection is available in the emulator. And also this partnership should need to be compulsarily done at the first time of the sync of the emulator. Because what happened to me is, the first time i didnt selected "Setup Partnership" rather i chose "connect without device setup" and afterwards whenever i opened WMDC, only the connection settings dialog pops up. The wmdc home/startup page containing the "Setup Partnership" never came. So I just reinstalled the WMDC and did setup partnership and now everything works fine... :)


    - rahul
    Friday, May 1, 2009 7:53 PM