none
Where and how do i remove the /FC compiler option in VS2005 RRS feed

  • Question

  • I am using VS2005 with PLatform builder.

    I DON'T want the __FILE__ macro to display the complete path with the file name.

     

    But I can find no way to RESET the /FC compiler option, can someone please help with this( I know VS2005 is old now, but... )

    Where and how do i remove the /FC compiler option in VS2005.

    • Moved by Barry Wang Thursday, January 12, 2012 3:40 AM More related to (From:Visual Studio Setup and Installation)
    Friday, January 6, 2012 11:34 AM

All replies

  • Hi Deepak_WinCE,

     

    Welcome to MSDN forum.

    Seems that you want to reset  your settings of Visual Studio 2005?

    In order to reset it, you can try these steps:

    1.       Open Visual Studio Command Prompt (2010) under Start menu -> All Programs -> Microsoft Visual Studio 2010  -> Visual Studio Tools (run it with Administrator privilege: right-click the program -> Run as administrator);

    2.       Try some devenv switches in command prompt:

    Run devenv /Resetsettings to reset your settings.

     

    Or you can refer to http://msdn.microsoft.com/en-us/library/027c4t2s.aspx  . You will find statements like this: To set this compiler option in the Visual Studio development environment

    1.       Open the project's Property Pages dialog box. For details, see How to: Open Project Property Pages.

    2.       Expand the Configuration Properties node.

    3.       Expand the C/C++ node.

    4.       Select the Advanced property page.

    5.       Modify the Use Full Paths property.

    Hope this can help.

     

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us
    Monday, January 9, 2012 8:44 AM
  • Thanks Barry,

     

    But none of the above is working for me, I tried these steps myself but I cannot locate the Property Pages->Configuration Properies->C/C++ node itself for my project.

     

    I am attaching a screen capture below of what I am getting in my project's property pages:

     

    I am using Visual Studio 2005 with Platform Builder for Windows CE 6.

    Monday, January 9, 2012 10:03 AM
  • Hi Deepak_WinCE,

     

    I’m doing some research on your issue. They may take some time. I’ll back later.

     

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us
    Wednesday, January 11, 2012 10:27 AM
  • Hi Deepak_WinCE,

     

    According to my research, your issue is more related to Windows Embedded Compact Platform Development. So I’d like to move your case there. (I can’t build the same environment as yours since my OS is corrupted and I need to repair it first).

     

    Best regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us
    Thursday, January 12, 2012 5:06 AM