locked
RIA Services Authentication issue RRS feed

  • Question

  • Hi

    I'm using RIA Services Authentication in my application. I'm providing login and change password feature.

    1. User login successfully and then do a logout.

    2. Change the user password. Password gets changed successfully.

    3. User is still able to login with his old password.

    Any help will be appriciated.

     

    Thanks

    Abhijeet

     

    Thursday, November 18, 2010 12:46 AM

All replies

  • There must be something you're missing. Have you debugged the application and checked from the Database that the password actually gets changed? Can you show us some of the relevant code? Without further information it's hard to tell where the problem might be.

    Thursday, November 18, 2010 1:31 AM
  • Telos,

    I'm authenticating against Active directory. when tried logging in via ADSI to Active directory I can pass authentication with new password only. The issue mentioned happens only via SL application (in OOB mode). Per my obseravation if I clean the cookies and temp files of IE the above mentioned issue gets resolved. Seems to be related to the authentication cookie but I'm still not sure on that.

    Thanks for your reply

    Thursday, November 18, 2010 1:49 AM
  • Ok, I can't say what's going on there. You said that you logout and then you change the password? Have you tried changing the password while logged in. Then logout and try a new login with a new password? 


    Friday, November 19, 2010 1:06 AM