locked
Internet Explorer 9 opening infopath forms up in the browser instead of client application RRS feed

  • Question

  • Hi,

    Since the upgrade to internet explorer 9, i have noticed an issue when trying to open an infopath form from a task. The form tries to open up in Internet Explorer instead of InfoPath.

    Before Internet Explorer 9 the link in the task used to open the form up in InfoPath since the application is installed on the clients machine, this has for some reason changed. Its an issue as the form isn't published as a web based form. The form opens up from the library fine where the form is saved just not from the link in the task that has been assigned to a person.

    This may not be the right forum, but I  couldnt work out which one it would be best to go to.

    Tuesday, April 19, 2011 2:47 AM

Answers

  • Hi,

     

    Thanks for your post.

    As I understand, you have published a InfoPath form (not a web based form) to SharePoint document library.  When you use IE 8 browser, the form will be opened in Client application; but now, when you use IE 9 browser, the form will try to be opened in the IE browser, am I right?

     

    First, What’s the version of your InfoPath? InfoPath 2007 or 2010;

    Second, there is a “Browser-enabled documents” choice for the document library, please check the “Open in the client application” and share the result.

    http://msdn.microsoft.com/en-us/library/bb267334(v=office.12).aspx

    • Marked as answer by Wayne Fan Saturday, April 23, 2011 4:11 AM
    Wednesday, April 20, 2011 2:49 AM

All replies

  • Hi,

     

    Thanks for your post.

    As I understand, you have published a InfoPath form (not a web based form) to SharePoint document library.  When you use IE 8 browser, the form will be opened in Client application; but now, when you use IE 9 browser, the form will try to be opened in the IE browser, am I right?

     

    First, What’s the version of your InfoPath? InfoPath 2007 or 2010;

    Second, there is a “Browser-enabled documents” choice for the document library, please check the “Open in the client application” and share the result.

    http://msdn.microsoft.com/en-us/library/bb267334(v=office.12).aspx

    • Marked as answer by Wayne Fan Saturday, April 23, 2011 4:11 AM
    Wednesday, April 20, 2011 2:49 AM
  • We also have the exact same problem.  We already have the setting correct in the library "Open in the client application". 

    Environment is Windows 7 / IE9 / Infopath 2010.

    Also, we have a link to the document in an email that now behaves the same way but if you navigate directly to the library and open the document, it opens in Infopath.

    Friday, March 2, 2012 9:24 PM
  • There are a couple ways to fix this:

    Option 1: to fix Infopath trying to open the form in the browser:

    Enable IE8 compatibility mode for the site that has the Infopath form. It's not ideal, but is easy to do and works. 
    Alternatively, you could try implementing option 2 below if possible

    Option 2: to fix the link (e.g. in your email document)

    By default all SharePoint 2010/MOSS documents will have something like this
       http://<URL_OF_THE_SITE> /_layouts/FormServer.aspx?XsnLocation=<URL_OF_THE_FORM>

    Fortunately, SharePoint also has a custom form to force downloading a file, which you can use by replacing the generated the link
       http://<URL_OF_THE_SITE>/_layouts/download.aspx?SourceUrl=<URL_OF_THE_FORM>

    This way no matter what, it will work. All the other browsers (Firefox, Safari, etc.) will work as well


    • Proposed as answer by Malachite04 Friday, August 16, 2013 3:27 PM
    Wednesday, April 11, 2012 7:59 PM