none
Unable to add vms to domain RRS feed

  • Question

  • Hi,

    I am using ARM template to add Vms to domain which are already deployed.

    I am getting the below error while adding them to the domain

    ERRx[
        {
            "code": "ComponentStatus/JoinDomainException for Option 3 meaning 'User Specified'/failed/1",
            "level": "Error",
            "displayStatus": "Provisioning failed",
            "message": "ERROR - Failed to join domain='test.com', ou='trialou', user='test.com\\admin001', option='NetSetupJoinDomain, NetSetupAcctCreate' (#3 meaning 'User Specified'). Error code 87"
        },
        {
            "code": "ComponentStatus/JoinDomainException for Option 1 meaning 'User Specified without NetSetupAcctCreate'/failed/1",
            "level": "Error",
            "displayStatus": "Provisioning failed",
            "message": "ERROR - Failed to join domain='test.com', ou='trialou', user='test.com\\admin001', option='NetSetupJoinDomain' (#1 meaning 'User Specified without NetSetupAcctCreate'). Error code 1332"
        }
    ]

    I am using a separate OU and DC is communicating with the vms perfectly. I was able to manually add the vms to the dc  but script is failing.

    Please provide a solution.

    Regards,

    Sree

    Friday, October 4, 2019 8:16 PM

Answers

All replies

  • Hi SreeShaji,

    Can you please help confirm if you are using the below ARM template for joining the VM to an existing domain or share the ARM template you are using ? 

    https://github.com/Azure/azure-quickstart-templates/blob/master/201-vm-domain-join/azuredeploy.json

    Friday, October 11, 2019 12:42 AM
  • Hi Sreeshaji,

    Can you share the part of the ARM template which is adding the VM to the domain?

    Monday, October 14, 2019 5:41 AM
    Moderator
  • Hi Bharath,

    I could resolve the issue,it was the OU path which caused the issue.

    I removed it since it was an optional parameter

    Thanks for your support

    Regards,

    sree


    Tuesday, October 15, 2019 6:52 AM