none
Framework problem RRS feed

  • Question

  • Hello,

    I am trying to program a program. When I am use the program it saying that I need framework 4.5 or lower.

    the problem and the files I have:

    http://srv1.jpg.co.il/8/562b25f26395a.jpg

    the program is a mod to gta v single (inside the visual studio using ScriptHookVDotNet).

    Saturday, October 24, 2015 4:08 PM

Answers

  • Hi,

    In order to use Script Hook .NET v2.4 you need at least .NET freamework version 4.5.2 official document Community Script Hook V .NET v2.4 and from the error you get the version which is install on machine that the visual studio is running is 4.5 so you need to upgrade your .NET framework version. In order to install latest nersion please do the following steps:

    1. Right click on your project in solution explorer

    2. Select properties

    3. Go to Application tab

    4. Select target framework drop download list and select the required framework version

    5. If it doesn't there > Select Install other version and from the web page download your required version and install it.

    Hope this helps you.

    Framework version change

    Thanks,

    Sabah Shariq


    Monday, October 26, 2015 8:56 AM

All replies

  • Hi my friend,

    Thank you for posting in MSDN forum

    As you can see from the Error List:

    This program requires: .NET Framework ≥ 4.5.2

    I suggest you change Target framework into .NET Framework 4.5.2.

    If you haven’t install .NET Framework 4.5.2 on your machine,

    I recommend you go to Microsoft official website to download .NET Framework 4.5.2.

     

    Best Regards,

    Wen Xu


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Monday, October 26, 2015 6:17 AM
    Moderator
  • Hi,

    In order to use Script Hook .NET v2.4 you need at least .NET freamework version 4.5.2 official document Community Script Hook V .NET v2.4 and from the error you get the version which is install on machine that the visual studio is running is 4.5 so you need to upgrade your .NET framework version. In order to install latest nersion please do the following steps:

    1. Right click on your project in solution explorer

    2. Select properties

    3. Go to Application tab

    4. Select target framework drop download list and select the required framework version

    5. If it doesn't there > Select Install other version and from the web page download your required version and install it.

    Hope this helps you.

    Framework version change

    Thanks,

    Sabah Shariq


    Monday, October 26, 2015 8:56 AM