locked
Unable to deploy app

    Question

  • I have a computer with Windows 8 build 8400 on it.  I had installed VS2012 Ultimate RC.  I uninstalled that and, as near as I can tell, all of the components that were installed with it and then installed the VS2012 Express RC.  Any time that I try to deploy an app I get the following set of errors (obviously they differ depending on the solution).  I even get the set of errors with a brand new solution.

    Can anybody give me some ideas of how to fix this?

    1>------ Deploy started: Project: App2, Configuration: Debug Win32 ------

    1>Error : DEP0700 : Registration of the app in the layout folder "C:\Users\dilts_000\documents\visual studio 2012\Projects\App2\Debug\App2\AppX" failed.

    1>error 0x80070003: windows.licensing failed to update critical data for cd205981-1d37-44c3-ba8d-39fb60aea1e7_1.0.0.0_x86__r3vwwsgmxgm1j.  Try again and contact the package publisher if the problem persists.

    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

    Saturday, July 14, 2012 3:28 AM

Answers

  • I went through the system event logs and noticed errors about not being able to find files every 30 seconds.  I used the new refresh feature and reinstalled VS2012 Express and everything is working now.  My guess is that I was a little too thorough when I tried to uninstall all of the components that VS2012 Ultimate installed.
    • Marked as answer by diltsman Tuesday, July 17, 2012 3:34 AM
    Tuesday, July 17, 2012 3:34 AM

All replies

  • I have the same issue. Do you have a suggestion about this?

    Hai

    Monday, July 16, 2012 9:46 AM
  • Hello,

    that hresult equates to path not found.   if you go to computer management -> right click on the computer node in explorer, select manage, in the computer management windows, expand system tools | Task scheduler | Task scheduler library | microsoft | Windows | WS.

    Any errors when opening up any of the nodes above?  Is there a license validation task with a ready status?

    thanks!

    mike

    Monday, July 16, 2012 8:46 PM
    Moderator
  • When I select Task Scheduler it pops up a dialog saying, "The remote computer was not found."  It does not allow me to expand that.
    Tuesday, July 17, 2012 2:02 AM
  • I went through the system event logs and noticed errors about not being able to find files every 30 seconds.  I used the new refresh feature and reinstalled VS2012 Express and everything is working now.  My guess is that I was a little too thorough when I tried to uninstall all of the components that VS2012 Ultimate installed.
    • Marked as answer by diltsman Tuesday, July 17, 2012 3:34 AM
    Tuesday, July 17, 2012 3:34 AM