none
Microsoft Net 2.0 install RRS feed

  • Question

  • While installing .NET Framework 2.0, I get the following error, "Setup cannot continue because this version of the .NET Framework is incompatible with a previously installed one. For more information, see http://support.microsoft.com/kb/906894.

    I have don't have . NET Framework 2.0 SP1 installed.  I do have .NET Frameowrk 1.1 installed.  Do I need uninstall .Net Framework 1.1 before installing 2.0?

     

    Thanks,

    Tarthian

    Monday, April 5, 2010 3:48 PM

Answers

  • Hi Tarthian,

    Thank you for your post.

    You don't need to remove .NET 1.1 before you install .NET 2.0. They can co-exist on the same machine.

    Some clarification with you:
    What's your OS?

    If you're running Windows Vista or later OS, .NET Framework 2.0 and 3.0 are shipped with it as OS components. We don't need to manually install it.

    If you're running Windows XP or Windows Server 2003, to install .NET Framework 2.0 on your machine, could you please try the following steps?

    1. Download .NET Framework 2.0
        or
        .NET Framework 3.5 Service Pack 1 (Full Package) which will install .NET 2.0 and 3.0 as prerequisite
        Note: You can try some download manager software to help downloading.

    2. Use Cleanup tool to clear the failed installation of .NET Framework 2.0

    3. Run the installer to install .NET 2.0 or .NET 3.5 SP1 with Administrator Privilege

    4. If any problem occurs during the installation, use Collect tool to collect the log files for further troubleshooting.

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET 2.0 or .NET Framework 3.5 SP1 full package
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Send vslogs.cab file to me (v-yicche@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Tuesday, April 6, 2010 8:41 AM typo
    • Marked as answer by YiChun Chen Monday, April 12, 2010 2:39 AM
    Tuesday, April 6, 2010 8:40 AM

All replies

  • Hi Tarthian,

    Thank you for your post.

    You don't need to remove .NET 1.1 before you install .NET 2.0. They can co-exist on the same machine.

    Some clarification with you:
    What's your OS?

    If you're running Windows Vista or later OS, .NET Framework 2.0 and 3.0 are shipped with it as OS components. We don't need to manually install it.

    If you're running Windows XP or Windows Server 2003, to install .NET Framework 2.0 on your machine, could you please try the following steps?

    1. Download .NET Framework 2.0
        or
        .NET Framework 3.5 Service Pack 1 (Full Package) which will install .NET 2.0 and 3.0 as prerequisite
        Note: You can try some download manager software to help downloading.

    2. Use Cleanup tool to clear the failed installation of .NET Framework 2.0

    3. Run the installer to install .NET 2.0 or .NET 3.5 SP1 with Administrator Privilege

    4. If any problem occurs during the installation, use Collect tool to collect the log files for further troubleshooting.

    The steps to collect the log:
    - Try to clean your "%temp%" folder (Start Menu >> Run >> Type "%temp%")
    - Install .NET 2.0 or .NET Framework 3.5 SP1 full package
    - Collect the logs from "%temp%" folder
       Collect tool: http://blogs.msdn.com/heaths/archive/2008/05/09/visual-studio-and-net-log-collection-utility.aspx
    - Send vslogs.cab file to me (v-yicche@microsoft.com)
      Note: Please attach the link of this post in the mail.

    Hope this helps! If you have any concern, please feel free to let me know.

    Best regards,
    Yichun Chen

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Edited by YiChun Chen Tuesday, April 6, 2010 8:41 AM typo
    • Marked as answer by YiChun Chen Monday, April 12, 2010 2:39 AM
    Tuesday, April 6, 2010 8:40 AM
  • Are you suggesting we'll need to do 1+2+3+4 or only 2/3/4 if the problem persists?

    The cleanup tool looks pretty scary & complex to me!

    edit

    I used "
        .NET Framework 3.5 Service Pack 1 (Full Package) which will install .NET 2.0 and ..."

    but my original problem persisted. Now I can't uninstall 2.0

    Friday, May 25, 2012 11:55 AM
  • As you have replied to a thread that is over one year old, please provide details of your issue.

    What is your Windows version? What .NET Framework version are you trying to install?

    The cleanup tool linked in the old answer is no longer recommended for use, except as a last resort.

    If you have an issue with a .NET Framework install, provide the information requested above, and your complete install logs as follows:

    Please collect your install logs with this:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E0DA314F-6216-4A18-BC6B-7D29CF83AF20&displaylang=e&displaylang=en

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Friday, May 25, 2012 12:07 PM