locked
ASP file with HTTP 500 Internal Server Error RRS feed

  • Question

  • User-130196783 posted

    I have seen the same questions but my problem seems a bit different.  My computer is WindowXP Pro and IIS 5.1 is installed.  I made sure all the components of IIS are installed.  I ticked the World Wide Web Services when I installed the IIS. 
    When I typed http;//localhost on the Internet Explorer 7,  Error message comes out so I made myself a default html page saying that this is a test page.  That is fine.  I can get that page.  And any html files I created and saved in www.root folder.  I can see in the Internet Explorer after typing http;//localhost/anything.html.  But as soon as I create an ASP page and saved in www.root folder, HTTP 500 Internal Server Error Page cannot display comes out in Internet Explorer.
    Ther are two asp files already in www.root folder I did not make those, they came with IIS.  One call iisstart.asp and another call localstart.asp.
    I typed http;//localhost/iisstart.asp and also I typed http;//localhost/localstart.asp but result is the same.  HTTP 500 Internal Server Error Page cannot display.
    When I double clicked the iisstart.asp file in the www.root folder,  It opens up with the Dreamweaver and saying as follows.

    Under Construction(www.root/iisstart.asp)
    Under Construction  The site you were trying to reach does not currently have a default page. It may be in the process of being upgraded and configured. Please try this site again later. If you still experience the problem, try contacting the Web site administrator.

    When I double clicked the localhost.asp file in the www.root folder, it opens up with Dreamweaver and saying as follows.

    Wellcome to Window Xp Server Internet Services(www.root/localstart.asp)
    Your Web service is now running. You do not currently have a default Web page established for your users. Any users attempting to connect to your Web site from another machine are currently receiving an Under Construction page. Your Web server lists the following files as possible default Web pages: . Currently, only iisstart.asp exists.To add documents to your default Web site, save files in .

    Can anybody tell me what I should do?
    Am I missing something to do?
    Thanking you in advance.

     


     

     

     

     

    Wednesday, June 27, 2007 7:21 PM

Answers

  • User989702501 posted

    Well, have you try put in user into the local admin groups ? if that doens't help, then it is not permissions issue.

    Have you aslo try register the dll ? any error msgs ?

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, July 11, 2007 6:40 AM

All replies

  • User1073881637 posted

    Turn off friendly errors on your browser and see what is really displayed.  This is in internet options, advanced.  Please post the error. 

    Thursday, June 28, 2007 12:18 AM
  • User989702501 posted

    Forget iisstart.asp / localstart.asp. create a simple hello.asp with response.write "hello", put it at the wwwroot folder, then browse http://localhost/hello.asp.

    If you still getting 500 error, try -
    HOW TO: Troubleshoot an "HTTP 500 - Internal Server Error" Error Message
    http://support.microsoft.com/?id=311766

    then post the relevant event viewer error here.


     

    Thursday, June 28, 2007 12:20 AM
  • User-130196783 posted

    Hi! Steve,

    Thank you very much for your help.
    I have turned off the friendly http error message on my browser.  The result is as follows.   I have created a simple ASP page as well saying only hello but the result is the same.

     Active Server Pages error 'ASP 0201'

    Invalid Default Script Language

    The default script language specified for this application is invalid.

    If you can tell me the possible problem from this,  I will be very gratefull.
    Thank you very much.

    Chiaki

     

    Thursday, June 28, 2007 3:51 AM
  • User-823196590 posted

    Start here:
    http://www.aspfaq.com/show.asp?id=2371

    Thursday, June 28, 2007 8:16 AM
  • User-130196783 posted

    Hello, tom,

    Thank you very much for writing to me.
    I am a bit shame to ask you this but where I can find Internet Services Manager to do the application configuration?
    I looked everywhere but I cannot find it.  My computer is WindowXP Pro.
    Kind regards,

    Chiaki

     

    Thursday, June 28, 2007 11:43 AM
  • User989702501 posted

    The detail is actually inside the article... which link to
    http://support.microsoft.com/default.aspx/kb/296626

    if this doesn't help, try
    http://msmvps.com/blogs/bernard/archive/2006/04/03/88985.aspx

     

    Thursday, June 28, 2007 11:42 PM
  • User-130196783 posted

    H!, Gbernard,

    Thank you very much for the advice you gave me.
    I have tried everything without success.
    I do not know what to do now.  I do not know who I can take my computer to check to.
    Most of the computer repairmen have no idea about IIS.
    Is there anyone I can call and can the persson instruct me what to do?  Or Is there somewhere I can take my computer to check?
    It is now beyond my ability.
    I have installed IIS Diagnostic software  and it's said many many errors in it but I do not know how to change.
    I thought I changed all what I could.
    Thank you very much.

     

     

     

    Monday, July 9, 2007 8:44 AM
  • User-823196590 posted

    If you can't find the IIS Manager (Start -> Control Panel -> Administrative Tools) then you probably need to re-install IIS and all of its components.

    Monday, July 9, 2007 8:53 AM
  • User-130196783 posted

    Hi! Tom,

    I am sorry I already found the IIS Manager( I did not know the Internet Information Services dialogue box is the IIS Manager).
    I have tried all the instruction of http://msmvps.com/blogs/bernard/archive/2006/04/03/88985.aspx.
     And no success.
    Thank you for sending the message but I do not know what to do now.

    Kind regards,

    Chiaki

     

     

    Monday, July 9, 2007 10:12 AM
  • User-1853252149 posted

    Did you look at and follow the post Tom made?  Follow this:

    http://classicasp.aspfaq.com/general/why-do-i-get-invalid-default-script-language-errors.html

    Let us know exactly what you found.

    Jeff

    Monday, July 9, 2007 11:34 AM
  • User-130196783 posted

    Hi! Jeff,

    Thank you very much for your advice.
    I did look at the page you gave me and I did try to enable both Server- and Client-side debugging but it did not make any difference.
    I will try something else and I will come back to you.

    Kind regards,

    Chiaki

     

     

     

     

     

     


    Tuesday, July 10, 2007 6:31 AM
  • User989702501 posted

    Well, have you try put in user into the local admin groups ? if that doens't help, then it is not permissions issue.

    Have you aslo try register the dll ? any error msgs ?

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, July 11, 2007 6:40 AM
  • User-130196783 posted

    Hello, Qbernard,

    Fantastic!   I have done it.
    Thank you very very much for your advise.   I put user into admin groups using computer management. Now it is working.
    After a few months struggle I finally got it.   You made me so happy.   I am thanking you a million.

    Kind regards,

    Chikai

     

    Saturday, July 14, 2007 10:09 AM
  • User989702501 posted

    Errr. that is just one of the suggestion workaround.. and this is just to check if it was related to permissions.
    So, now you should remove user from admin group, then get filemon to trace the access issue.

     

    Sunday, July 15, 2007 11:57 PM
  • User-130196783 posted

    Hello,  Bernard,

    I am sorry I didn't see your reply until today.  Thank you again for you reply.
    By the way what is the filemon?
    And I was going to send another question.
    I already had 2 website published using Front page with Front page extension.   I was only practising building databased asp page with Dreamweaver not with Front page.
    Today I was try to update my existing 2 websites  and tried to publish through Fronpage but I cannot connect either of my websites to my remote server.
    I asked my remote server to reinstall the Front page extension and they have done so but still I cannot connect to my remote server.
    It was working perfectly fine until I was fiddling with ASP file. Is that anything to do with it?
    Can you give me any suggestion?  I know this question is nothing to do with IIS but I do not know who to ask.
    Thanking you in advance.

    Chiaki

     

     

     

    Tuesday, July 24, 2007 6:39 AM
  • User1073881637 posted

    Filemon aka file monitor is a free tool that is good in tracking down file / folder permissions errors. http://www.microsoft.com/technet/sysinternals/utilities/filemon.mspx  What errors are you getting when you try to publish with FrontPage?  Can you ping your remote server? This will test connectivity.  You might want the Admin of the server to run 'check and fix' on the FrontPage extensions.   This can correct FrontPage publishing errors.  Your ASP file will not mess up your ability to publish with frontpage, it is just another file type FrontPage would publish. 

    Tuesday, July 24, 2007 6:45 AM
  • User-130196783 posted

    Hello,  Steve,

    Thank you very much for your advice.
    I typed my website address using open site in Frontpage. Error message said you do not have permission to access this web folder location.
    So I cannot use administrative tool.   I must have messed up with permission.
     I have to find out what I have done.

    Yours sincerely,

    Chiaki

     

    Tuesday, July 24, 2007 8:28 AM
  • User-130196783 posted

    Hello Steve,

    I am sorry my Frontpage uploading problem was nothing to do with the permission problem.  My telephone line was cut one stage, that is why I think.  It is working fine now.
    I will look at FileMon for the IIS issue.
    Thank you very much.

    Yours sincerely,

    Chiaki

     

    Thursday, July 26, 2007 7:41 AM
  • User1073881637 posted

    Darn I was going to suggest that next. :)   Good luck, filemon is a handy tool!

     

    Thursday, July 26, 2007 4:21 PM
  • User-130196783 posted

    Hi! Steve,

    Thank you very very much for your help.

    KInd regards,

    Chiaki

     

     

    Friday, July 27, 2007 8:53 AM