locked
Can't register Developer License on Visual Studio 11 Beta for Windows 8 RRS feed

  • Question

  • I can't seen to register a Developer License on Visual Studio 11 Beta for Windows 8.  It keep saying can't contact licensing servers and asking me to log in with my live ID again.  I am a MSDN subscriber but Visual Studio 11 Profesional Beta does not allow me to create Metro apps.  I can't run the Metro apps I have already created with the Developer Preview

    SB Software Developer



    • Edited by Sacha Bwin Wednesday, February 29, 2012 11:47 PM
    Wednesday, February 29, 2012 11:44 PM

Answers

  • Thanks for fixing it!  It works great now!!!

    SB Software Developer

    • Marked as answer by Sacha Bwin Wednesday, March 21, 2012 8:19 AM
    • Marked as answer by Sacha Bwin Wednesday, March 21, 2012 8:20 AM
    Wednesday, March 21, 2012 8:19 AM

All replies

  • Hello S B,

    Based on the1.3.3.9  Development of Windows Metro style apps is not supported on Windows Server 8 Beta part of the VS11 Beta Readme file:

    To develop a Windows Metro style app, you must have a developer license installed on a machine that is running Windows 8 Consumer Preview.  Because developer licenses are not available for Windows Server 8 Beta, you are unable to develop Metro style apps on that operating system. For more information about developer licenses, seeGetting a developer license.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, March 1, 2012 7:20 AM
    Moderator
  • I am running Windows 8 Consumer Preview.  I installed Both Express 11 Beta and Pro 11 Beta and the Metro is not available in Pro. 

    When I try to get a Developer License both from VS 11 Express Beta and from Power Shell this is what happens:

    Asks me if I Agree and yes I hit I Agree.

    Says "Contacting License Server"

    Asks me for my Microsoft account and I enter my live information. 

    It accepts it.

    Say "Renewing Your Developer License"

    Then

    Developer License
    We couldn't get you developer license for Windows 8 Consumer Preview
    Please check your network connection and try again. (My internet works great, nothing wrong with it and I've tried with Win. Firewall off as well)

    Hit Retry - Same Thing


    SB Software Developer

    • Proposed as answer by zou_pengcheng Monday, March 5, 2012 1:55 AM
    Thursday, March 1, 2012 9:27 AM
  • Having the same issue.  Any chance you found a solution?
    Saturday, March 3, 2012 4:43 AM
  • getting the same issue on a machine that was upgraded from Windows 7 x86 to Windows 8 consumer preview.

    Using VS 11 Ultimate beta.

    • Edited by Mike Saturday, March 3, 2012 4:25 PM
    Saturday, March 3, 2012 4:25 PM
  • I am having the same issue. It's really disappointing. I really wanted to try out the Metro SDK.
    Sunday, March 4, 2012 7:33 AM
  • I'm having the same issue.  I upgraded x64 Window 7 to the Windows 8 Customer Preview.
    Sunday, March 4, 2012 6:10 PM
  • I'm also experiencing this on a machine that I upgraded from Win7 x64 to Win 8 CP.
    Sunday, March 4, 2012 11:35 PM
  • Having the same issue.  Any chance you found a solution?
    Monday, March 5, 2012 1:56 AM
  • Hello, I just installed the new WIN 8 Consumer preview, and I have the following issues to add:

    I have three machines I am trying both the ultimate and express SKUs and get the same problem on all of these were UPGRADED from Windows 7.. I am glad that I image back up at this point is all I can say. The one machine I can install this on properly is the from scratch INSTALL.. Come-on folks this should not be so difficult, you've avoided this kind of licensing tracking and problems for years. Why turn it on now on such a big release and change for windows especially for developers who historically have been against this.. The one machine where it works it phones home each time I run the software and validates the licensing AGAIN, each time it's launched and I get errors if it's not connected to the internet..

    Anyway here are the errors I get.. TIME AND TIME again... Not Happy..

    Sincerely,

    Don Burnett Expression Blend MVP 2011-2012


    Don Burnett

    Monday, March 5, 2012 6:28 AM
  • I actually created a Win8 Hyper-V machine with a fresh install.  It works great and registers the license properly, although I wish it was on my main machine.  It's works well though, fairly fast and really responsive.  It's a temporary fix until we get a real fix for this issue.

    SB Software Developer

    Monday, March 5, 2012 6:50 AM
  • The only fix out there is to wipe and re-install.. Not cool Microsoft.. Between that and the problems that the Windows Phone install SDKs non-functionality and the ease of install I worry that many developers AND Designers will get frustrated and give up on making their first metro app, and the Windows Phone 7 people won't upgrade at all when the functionality between the two platforms has such synergy that they should..

    This lack of coordination of factions between internal teams at getting the preview right for consumers speaks not so well, but is very much like problems of the past..

    Don Burnett

    Tuesday, March 6, 2012 1:42 AM
  • so basicaly you are telling me that in order to get a working license, i have to have a legit fresh install of windows 8? and not upgrade? and then it will register? wth..that's bull***. 
    there has to be another way..
    Tuesday, March 6, 2012 3:39 AM
  • I'm getting the same thing on two of the four Win8 CP machines I've built--the two that were upgraded from Win7 x64. The two I built from scratch have no such problem.

    Tuesday, March 6, 2012 4:21 AM
  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thanks.


    Vicky Song [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, March 6, 2012 8:01 AM
    Moderator
  • My install of Win8 CP was a clean install and I also get the same error.

    I don't believe that this problem has anything to do with Win7 to Win8 CP upgrades vs. a clean install of Win8 CP.

    The licensing mechanism is just plain broken for now.

    I don't know why Microsoft has such a problem creating software that is not broken ... but they do, again and again (create broken software).  I guess they have a hard time hiring competent programmers.


    Charles S. Cotton



    Tuesday, March 6, 2012 2:03 PM
  • I managed to get my developer license twice successfully with the steps below (re-formatted for the second time), but it may not work for all, just thought I'd share since I couldn't get the license since yesterday.

    1. Do a fresh install of Win 8 CP
    2. Create a Local account on purpose
    3. Install VS11 right away
    4. Create a new metro project
    5. Get prompted to sign in with my Microsoft Account as seen below

    6. Get notified that the developer license has been assigned successfully

    Tuesday, March 6, 2012 2:32 PM
  • ı have the same issue  any good news ? hayret birsey yaa

    <(+)>--C#_WPF_SİLVERLİGHT_XBAP_HTML--<(+)>

    Wednesday, March 7, 2012 6:42 AM
  • Same problem -- upgraded from Win7 x64 Professional.  Any guidance would be great as I'd prefer not to have to wipe and clean install.

    Wednesday, March 7, 2012 5:10 PM
  • The only solution I have come up with is a temporary one but it work well.  Setup a clean Win8 x64 install on a Hyper-V machine in your existing Win8 upgraded machine. 

    Go you Programs & Features in Control Panel.  Click on Add Remove Windows Features.  Check the Hyper-V stuff.  Restart.  Hit the Windows key on the keyboard and type hyper.  The hyper-V Manager should come up and hit enter.  Setup a new Hyper-V machine and install Windows 8 on it and Visual Studio 11 Beta.  Mine registered first try!  It works till my main machine can be fixed.


    SB Software Developer

    Wednesday, March 7, 2012 8:36 PM
  • Hopefully I will get the same results, I am in the process of installing a Hyper-V machine.  Doing a clean install is just not an option and unfortunately Microsoft seems to not be working this issue at all.

    R. K. Walters

    Wednesday, March 7, 2012 10:00 PM
  • rrr  ı still  wait and ı loose my wishing  to make metro style app thanks tecnology ;)  

    <(+)>--C#_WPF_SİLVERLİGHT_XBAP_HTML--<(+)>

    Wednesday, March 7, 2012 10:57 PM
  • I can confirm the experience that S B had, after creating a new Hyper-V machine and installing Visual Studio 11 beta, I got a developers license.  This certainly seems to be an issue with machines that were upgraded in place from 7 to 8.

    R. K. Walters

    • Proposed as answer by mrCaddy56 Wednesday, March 7, 2012 11:28 PM
    Wednesday, March 7, 2012 11:27 PM
  • For those still having issues getting the key, please look at this thread below and try the solution.

    http://social.msdn.microsoft.com/Forums/en-US/toolsforwinapps/thread/9b6d1274-6dd0-45a0-8814-29f0500b9fa9

    • Edited by systemx Friday, March 9, 2012 2:03 AM
    Thursday, March 8, 2012 1:08 AM
  • Any update on this, Vicky? Unfortunately the one workstation I have available for Metro app development is the one machine I *cannot* do a clean Win8 CP build on due to pre-installed software I cannot install on a fresh platform. It's been almost two weeks of waiting on this now, and some of us are still hoping to get started. Thanks for your help.
    Monday, March 12, 2012 3:31 PM
  • Hi Vaughn H, have you tried the solution from the link that I posted? Does it work for you?
    Tuesday, March 13, 2012 11:45 AM
  • @systemx, yes, I looked at your solution, but as I just stated in my last post, it won't do. If you weren't familiar with how your suggestion works, the "Just personal files" upgrade option retains only your files (as it implies & describes) and does not retain any of your desktop applications. They must be reinstalled afterward. I don't have the option of reinstalling all my desktop apps afterward with my machine's configuration and OEM pre-installed software.
    • Edited by Vaughn H Tuesday, March 13, 2012 5:39 PM
    Tuesday, March 13, 2012 5:38 PM
  • Thanks for fixing it!  It works great now!!!

    SB Software Developer

    • Marked as answer by Sacha Bwin Wednesday, March 21, 2012 8:19 AM
    • Marked as answer by Sacha Bwin Wednesday, March 21, 2012 8:20 AM
    Wednesday, March 21, 2012 8:19 AM
  • Not for me.  I've installed the hotfix twice, both time restarting machine.  Same error.  Would someone be kind enough to describe exactly what they did after following the instructions in the hotfix update.  Did you open VS11 first or go elsewhere to secure the developers license before opening VS11??
    Friday, March 30, 2012 7:05 AM
  • I just installed the update through Windows Update and knew it was for that as I always read the update info.  After that restarted and it worked.

    SB Software Developer

    Friday, March 30, 2012 7:12 AM