none
Error in Virtual Machine RRS feed

  • Question

  •  

    Good afternoon to all


    I'm having a little problem with Hyper V. A power failure occurred and the server was shut down incorrectly. In return, some VMS now no longer work. In the console of the server manager, Hyper V, by clicking on them the following error message appears:

    "An error occurred while attempting to launch the Virtual Machine Connection application for the selected virtual machine"


    I got to them but not the reboot. I tried to create a new machine using the files of vhd, it works, but with the older settings, because some snapshots were made and does not come with these settings. I tried to download the import virtual machine, but he did not. Someone has got a similar problem?
    Thursday, January 29, 2009 2:32 PM

All replies

  • One thing that I've noticed about this: I can connect to the virtual machine with a remote desktop connection.

    The Hyper-V Event Log EventID for the problem (for me) is 14050, which is a "failed to register service principal name" error.  A search through a search engine turned up the following from 
    http://www.aspdeveloper.net/tiki-index.php?page=VirtualServerEvents_14050, and I've copied this information here (in blue) from that webpage. 

    Log Name: Microsoft-Windows-Hyper-V-VMMS/Admin
    Source: Hyper-V-VMMS
    Event ID: 14050
    Level: Error
    User: SYSTEM
    OpCode: Info

    You may run into this error if your domain is not established correctly.

    When I saw this the computer had a DHCP assigned address on a network adapter which wasn't used on the host. The DHCP address conflicted with the route to the domain controllers - i.e. to reach the domain controllers the source IP was the DHCP assigned address, NOT the primary NIC that should have been used. This had the wrong firewall rules and therefore couldn't talk to the domain controller correctly.

    This SHOULD be a very uncommon mistake.

    You can check that your route to your domain controllers is how you expect via "tracert" and ipconfig /all

    Also check your DNS.


    I haven't tried this yet, but thought I would pass along the information that I've recently found and am going to look at.  This, to me, sounds like the most plausible answer, because the virtual server that I have worked without incident until I put the DHCP service on the virtual server.
    • Proposed as answer by Joerodrigue Monday, November 7, 2016 9:07 PM
    • Unproposed as answer by Joerodrigue Monday, November 7, 2016 9:07 PM
    Wednesday, March 18, 2009 6:43 PM
  • Microsoft in their infinite wisdom, has decided to tie the hypervisor services on a physical machine to active directory (only if you join this host to the domain).  So if you active directory controller isn't available, then none of your vm's will be accessible to start (ie if you had shut them down and rebooted the host machine).

    So long story short:
    SBS 2008 supports running SBS 2008 as a VM on a physical machine.  If you join your physcial machine to the domain that you setup with sbs 2008, then when you reboot that host computer, your SBS vm (aka your domain controller) will not be able to start due to this totally messed up and nonsensical decision.
    answer?  to just remove the host computer from the domain and join it to a workgroup.  Walla, all VM's are functional again.

    Thanks microsoft.
    Wednesday, January 27, 2010 10:04 PM
  • Thanks, that worked like a charm.  I removed the physical box from the Domain to a workgroup.  Rebooted.  Then added physical box back into domain and that fixed it.  I could once again see domain accounts in the admistrators group on the local box in user manager.  And I could start the VM computers with my domain accounts like there was no problem at all.  This worked great for me.  Thanks again.
    Thursday, May 27, 2010 5:19 PM
  • I ran into this issue as well. I didn't want to leave the domain, since I use it for work. My server is not on the location with domain, but connects automatically on boot, however, not before Hyper-V tries to register the SPN with the Domain Controller. I tried this http://www.google.com/url?sa=t&rct=j&q=hyper%20v%2014050%20failed%20to%20register%20service%20principal%20name.&source=web&cd=1&sqi=2&ved=0CDAQFjAA&url=http%3A%2F%2Fsocial.technet.microsoft.com%2Fwiki%2Fcontents%2Farticles%2F1340.aspx&ei=ji-IT6GbLouFtge4nuW-CQ&usg=AFQjCNFNY3JIjgW_fLKvtO24I8FmpKOmPw which worked, but I didn't want to do this after every boot, so I put a .bat file in my startup folder like this:

    ECHO restart VMMS due to error 14050 when Domain Controller cannot be reached
    ping -n 15 127.0.0.1 >NUL
    net stop nvspwmi
    net start nvspwmi

    Error is still logged, but everything works after the .bat runs.

    Friday, April 13, 2012 2:20 PM