MDS 2017 Excel Add-on - Object reference not set to an instance of an object when connecting RRS feed

  • Question

  • Hi,

    I have followed all documentation and online guides to set up MDS in SQL 2017 RTM. It all works and connects fine, including browse to the hompage from my machine fine.

    EXCEPT using the MDS Excel add-in for SQL 2017 (onExcel 2016 64 bit). When adding a connection and clicking the 'Test' or 'Connect' buttons, nothing happens. Then I switched on the VSTO_SUPPRESSDISPLAYALERTS environment variables, and sure enough it's generating an exception:

    Object reference not set to an instance of an object.

    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Microsoft.MasterDataServices.ExcelAddInCore.AddInAdapter.Connect(ServiceAddress address)
       at Microsoft.MasterDataServices.ExcelAddInCore.Connections.ConnectButton_Click(Object sender, EventArgs e)
       at System.Windows.Forms.Control.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnClick(EventArgs e)
       at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ButtonBase.WndProc(Message& m)
       at System.Windows.Forms.Button.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    Any idea what could be going on?

    Many thanks,


    Thursday, October 4, 2018 12:36 AM

All replies

  • whaaa! Anyone? I'm really stumped by this. I've have tried many many things now to resolve this, including superstition based rituals not at all based in science.
    Thursday, October 4, 2018 8:24 PM
  • Hi,

    I found the fix to this: In Excel, go into File >  Options > Add-ins > COM-Add-Ins, and un-check the MDS add-on, click OK. Then go back into COM-Add-ins and re-enable the MDS Add-on. Then connection will work.

    Chur bro.

    Monday, October 8, 2018 7:45 PM