locked
Exception while migrating simple procedures from Oracle to SQL server RRS feed

  • Question

  • The error is as follows-

    Converting procedure POC.LIST_A_RATING ...

    Conversion finished with 0 errors, 0 warnings, and 0 informational messages.

    An unexpected error occurred. Please send the log file to product support. For more information, see "Getting SSMA Assistance" in the product documentation.

    The type initializer for 'Microsoft.SSMA.Framework.Oracle.Parser.OracleParserCacheManager' threw an exception.

     

    content from log-

    Exception has been thrown by the target of an invocation.

    site: System.Object _InvokeConstructor(System.Object[], System.SignatureStruct ByRef, IntPtr)

    source: mscorlib

    at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)

    at System.RuntimeMethodHandle.InvokeConstructor(Object[] args, SignatureStruct signature, RuntimeTypeHandle declaringType)

    at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)

    at System.Security.Cryptography.CryptoConfig.CreateFromName(String name, Object[] args)

    at System.Security.Cryptography.MD5.Create(String algName)

    at System.Security.Cryptography.MD5.Create()

    at Microsoft.SSMA.Framework.Generic.Parsers.DefaultParserCacheManager..cctor()

    Tuesday, July 12, 2011 4:51 AM

Answers

  • On installing SSMA for Oracle 5.0 I started getting the following additional error in the log- at System.Security.Cryptography.MD5CryptoServiceProvider..ctor()
    [Gui: Error] [3676/11] [2011-07-13 10:56:04]: LowLevelAdapter.ConvertTree : Convert error: System.TypeInitializationException: The type initializer for 'Microsoft.SSMA.Framework.Oracle.Parser.OracleParserCacheManager' threw an exception. ---> System.TypeInitializationException: The type initializer for 'Microsoft.SSMA.Framework.Generic.Parsers.DefaultParserCacheManager' threw an exception. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.at System.Security.Cryptography.MD5CryptoServiceProvider..ctor()

    From the support article-http://support.microsoft.com/kb/811833, I figured ou that I needed to turn FIPS option to disabled in my registry. After performing this change, I was able to convert stored procedures without this issue.

     

     

    • Marked as answer by MModak Wednesday, July 13, 2011 6:32 AM
    Wednesday, July 13, 2011 6:32 AM

All replies

  • On installing SSMA for Oracle 5.0 I started getting the following additional error in the log- at System.Security.Cryptography.MD5CryptoServiceProvider..ctor()
    [Gui: Error] [3676/11] [2011-07-13 10:56:04]: LowLevelAdapter.ConvertTree : Convert error: System.TypeInitializationException: The type initializer for 'Microsoft.SSMA.Framework.Oracle.Parser.OracleParserCacheManager' threw an exception. ---> System.TypeInitializationException: The type initializer for 'Microsoft.SSMA.Framework.Generic.Parsers.DefaultParserCacheManager' threw an exception. ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: This implementation is not part of the Windows Platform FIPS validated cryptographic algorithms.at System.Security.Cryptography.MD5CryptoServiceProvider..ctor()

    From the support article-http://support.microsoft.com/kb/811833, I figured ou that I needed to turn FIPS option to disabled in my registry. After performing this change, I was able to convert stored procedures without this issue.

     

     

    • Marked as answer by MModak Wednesday, July 13, 2011 6:32 AM
    Wednesday, July 13, 2011 6:32 AM
  • That's incomplete, follow this: http://ipswitchft.force.com/kb/articles/FAQ/Windows-Platform-FIPS-validated-crypto-message-appears-trying-to-access-Login-aspx-1307565986146

    From the page: "

    1. Go to Start > Control Panel > Administrative tools > Local Security Policy. The Group Policy dialog appears. 
    2. Under the "Local Policies" heading, select "Security Options" and look for the entry, "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing." 
    3. If entry this is enabled, disable it.

    Also, open the registry editor and browse to the following path.  Make sure this registry subkey is set to 1:

    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\fipsalgorithmpolicy"

    Radu P.

    Tuesday, September 17, 2013 8:27 PM